Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Amana Refrigerator with Ice problem on Evaporator


  • Please log in to reply
2 replies to this topic

#1 seligman

seligman

    Unsui

  • Grasshoppah
  • Pip
  • 1 posts

Posted 16 June 2005 - 02:49 PM

Amana Refrigerator Model TZ23QE, Mfg No. P1114904WE

My refrigerator doesn't want to self-defrost properly. About a week ago, I noticed both the freezer and refrigerator were getting less and less cold. Looked at the rear wall in the freezer and noticed ice buildup about 1/4 thick. So I took off the back panel and found ice everywhere all over the evaporator coils and surrounding area. I manually de-iced that area, put everything back together, and all was good again - for the last five to six days. Today, the cooling problem has started to return and I spotted new ice forming on the rear panel.

Initially, I thought it came from the freezer door being left partially open a couple days earlier for a period of a few hours (this was the first time). Now that the same problem has returned, I'm thinking it is much more.

Suggestions?


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 kdog

kdog

    RoughShod

  • Academy Fellow
  • PipPipPipPipPip
  • 7,465 posts
  • Location: Canada
  • Flavorite Brew:Dickens Cider

Posted 16 June 2005 - 08:04 PM

one or more components in your automatic defrost circuit has failed(timer,defrost heater,termination switch)                                        :(
Help us keep the lights on: buy appliance parts here ==> http://repairclinic.com

For service manuals and lots of other goodies, become an Apprentice ==> Apprenticeship

#3 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,696 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 17 June 2005 - 05:33 AM

Does sound like a defrost system failure.  Further diagnostic help here:

http://fixitnow.com/...pair-manual.htm




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics