Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

gogugogu

Asko Dryer T761

4 posts in this topic

The dryer stoped working.

I did clean it up (the fan was full) and reset it.

Then it worked a few loads.

Then stoped again - the display was on and the  dryer was making a small noise.

I opened the dryer - first the top panel, then the back panel and then the front panel. I clean it some more and put it back together. Now the power is on but the display panel is not on and makes no noise.

Any suggestion how to fix it?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

You're gonna need the pull the meter on this one, Budrow.  Sounds like at first you may have had a problem with the motor; it was getting voltage but unable to kickoff and start rotating.  That could be anything from an obstruction to a bad motor.  Now, after having taken it apart and putting it together and the new development of it not doing anything, you may have knocked a wire loose in the disassembly, e.g., door switch-- if this is disconnected, it won't run.  Some other things to check:

THE MACHINE WILL NOT START

Check

• that the outer lid is properly closed.

• that the mains power button is pressed in.

• that you have set the program or the desired

timer program correctly.

• that the condensation water tank is empty.

(T720/780)

• that if a power plug is used it is connected.

• that the fuses for the house electricity supply

are not blown. Change two of the fuses over.

It is not always visible from the outside when

a fuse is blown.

• that the overheating protection has not trip-

ped, see below.

Share this post


Link to post
Share on other sites

You are right. The door switch was offset. I reseted and started the dryer again.

Again it makes that noise. I believe as you say it is the motor - the drum is not rotating when the power is off.

Should I go for a new motor or  something else?

I forgot to mention that before I disassembled the drum smells like something was burned.  After disassembly I found a large amount of deposits in the heating element area. Is this where the smell come from? It smells only inside the drum.

Share this post


Link to post
Share on other sites

[user=22061]gogugogu[/user] wrote:

the drum is not rotating when the power is off.

I would hope so!  If that drum starts rotating with the power off, then you need an exorcist! 

The test you need to do is to make sure you're getting 120vac to the motor when you try to start the dryer (and with power applied, of course).

Share this post


Link to post
Share on other sites