Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn Circuit Fu, the ancient lost art of appliance repair…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
MattCombs

O'Keefe and Merritt Oven Malfunction

1 post in this topic

We recently moved our O'keefe and Merritt range (model #5050) in order to refloor. Moving it only involved sliding it forward and back a few times. Since we returned it to its original location and relit all of the pilots, the oven and separate broiler won't ignite. The burners are working fine. I read the thread about the timer causing problems, but the timer only works on the oven, not the broiler and we've never used the timer; in fact the range has never been plugged in except to see if anything electrical worked.I tried boosting the heat put out by the pilot by using a handheld lighter stick; this didn't help.I also read about a reset switch that may need to be pressed after moving, etc. but this model doesn't seem to have one. I looked everywhere under the hood. The pilot lights are good to go, but when the oven is turned on you don't hear any sound of gas feeding through.Any ideas? Thanks for your help!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!