Jump to content


Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Whirlpool side/side refrigerator/freezer stopped cooling


  • Please log in to reply
4 replies to this topic

#1 TNhunter

TNhunter

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts

Posted 02 July 2005 - 06:56 AM

I have a Whirlpool MOdel ED25QFXHB01 side/side refrigerator that stopped cooling yesterday. Both fans are running. The defrost timer seems to be operating correctly. The compressor was pretty hot to touch. When I first plug it in both fans come on and about 5-10 seconds later I hear the start relay click but don't really think the compressor is kicking on. I don't hear it and don't feel any vibration from it running. I just pulled of what I think is the start relay and it is rattling. I've read somewhere on here that if that is the case the start relay is fried. I'm wanting to make sure this is most likely my problem before buying the part, and I want to do this myself since local repair shops are wanting like $150 to come out and "fix" it. If this is indeed the part - what do I order and where? The part I have is a KLIXON 4SP1024. See pics below:

Posted Image

Posted Image


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Jedi Appliance Guy

Jedi Appliance Guy

    Senpai

  • Chief Appliantologist
  • PipPipPipPip
  • 701 posts

Posted 02 July 2005 - 07:01 AM

   Your diagnosis is correct.  You can get the part right at the bottom of this page.

#3 TNhunter

TNhunter

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts

Posted 02 July 2005 - 08:59 AM

Thanks - part will be ordered in just a few minutes.

#4 TNhunter

TNhunter

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts

Posted 12 July 2005 - 08:57 PM

I received the part today. Installed it and now problem solved. My refrigerator/freezer are cooling again. Thanks!

#5 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Master Samurai Tech
  • 29,442 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 13 July 2005 - 01:29 PM

:party:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics