Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Very Warm Beer (+Turkey) with very cold Freezer - GE Profile PDS22SBRALSS


  • Please log in to reply
102 replies to this topic

#21 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 09 April 2008 - 02:32 PM

[user=1]Samurai Appliance Repair Man[/user] wrote:

Nice pix, thanks for posting 'em! :dude:

Sharing the knowledge....sharing the knowledge.

----------------------

If anyone is in the same boat as me and they are thinking of doing a defrost I recomend the following.
1. Move all food to a new location.
2. Increase the fridge temp until the display says OFF.
3. Open the fridge and freezer doors up.
4. Now wait??

I also recomend accessing the back of the fridge and finding the drain.
The drain feeds into a tray in the back of the fridge. I recomend rerouting that line to a bowl or pan. Let the fridge drain into that rather than the back of the fridge tray.
While you are there, clean away any dust you see on the coils.
(I'll try and post a pic...may make more sense)

During the defrost I noticed that when the freezer door was open, the evap fan would run. If I shut the door, the fan would shut off. I'm guessing this is expected when the fridge is OFF, and defrost "mode" is needed.
After I defrosted the freezer, the fan stop running.

Anyways, I came home from work and temps were 0, 38F. And the evap fan was off.
Looks good so far, but I won't know if I have a defrost issue until it builds up again.

--------

Like I said... it appears to be running great. But if I still have a defrost issue, it may not show for sometime. I will inspect my thermodisc, heater element...etc,etc.

I will report my findings, and pics to help explain what I can!

 

Bob :D


 

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#22 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 11 April 2008 - 06:04 PM

So my temps are sitting pretty good. The evap fan no longers runs 24/7...so my kitchen is very quiet!

 

Here is the photo I mentioned earlier.  If you are going to do a big defrost and you don't want the water sitting in drain tray, just pull the drain tube out and feed it into a bucket or tupperware like I did.

 



Posted Image

#23 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 20 April 2008 - 03:05 PM

Well, Sad news...:(
I came home Saturday night to find my freezer at 11F and Fridge at 52F.
So I quickly pulled all the food out of the freezer, removed the drawers so I could get to the back panel.
I pulled out and the panel and found the evaporator coils frozen over.
In the white winter snow appearance.

I fed the drain, from the back of the fridge, into some tupperware for easy clean up, and then went at the evaporator with a hair dryer.

Now before I did that I unplugged the connector that feeds the thermodisc and heater. I measured 30 ohms. Which I'm assuming means closed thermodisc, and a heater with 30 ohms of resistance?

I melted all the frost over, 11 cups of water!
With the freezer comparment warm, fully melted and dry, I measured the resistance and I still got 30 ohms. I thought I should be seeing an infinite value here?  :?
With everything warm, wouldn't the thermodisc open?

This was late at night, so I put everything back together and went to bed.
When I came downstairs the following morning, the temps were dead on at 0F & 37F.

Anything I should look at next?

Posted Image

#24 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 20 April 2008 - 03:28 PM

The evaporator fan can't blow air through it if it's totaly frosted up.

from the manual:

The defrost heater is controlled by the evaporator thermistor and normally turns off at 70°F.

If the evaporator thermistor fails, the evaporator thermostat will turn off the defrost heater at 140°F and will reset at 110°F.

Looks like your Main Control Board is bad (determines when to defrost)
http://www.repaircli...R=154&N=1194711

 

00248040.jpg


.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#25 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 20 April 2008 - 04:05 PM

I just put in a brand new board. This is the 3rd board in 4 years. :(

And I just defrosted my fridge like 2 weeks ago. Can it frost up that fast?

#26 appl.tech.29501

appl.tech.29501

    Sensei

  • Appliantology Fellow
  • PipPipPipPipPip
  • 8,025 posts
  • Location: USA
  • Flavorite Brew:Waffle House Coffee

Posted 21 April 2008 - 11:45 AM

Yep, those friges can frost up in about 3 days...most in about two weeks, but the GE's go into a super cool mode right before defrost to keep the frige temps from rising too much, that why the frost up quicker.
If you would like to make a donation you may do so at the link below

One on one repair help now available !

http://homepage.mac....ppl.tech.29501/

http://twitter.com/ApplTech29501

http://www.facebook.com/ApplTech29501

www.eliteapplianceservice.org

#27 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 21 April 2008 - 04:48 PM

Wow, they frost up more than I thought they would. Is frost up based on the amount of time the freezer door is open?

Next weekend I plan on checking the freezer for frost.

If it's frosted up, I'll be checking the thermostat which is mounted on the evaporator, the heater element, and then check this thermistor for resistance.

 

Anything else I should check?

 

#28 appl.tech.29501

appl.tech.29501

    Sensei

  • Appliantology Fellow
  • PipPipPipPipPip
  • 8,025 posts
  • Location: USA
  • Flavorite Brew:Waffle House Coffee

Posted 22 April 2008 - 01:42 PM

Thats about it for starters, most likely the heater but if it is change the thermistor on the evap. coil as well. too enexpensive not to ;).
If you would like to make a donation you may do so at the link below

One on one repair help now available !

http://homepage.mac....ppl.tech.29501/

http://twitter.com/ApplTech29501

http://www.facebook.com/ApplTech29501

www.eliteapplianceservice.org

#29 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 23 April 2008 - 03:23 AM

I'm measuring 30 ohms for the element. 30 ohms should be good.

I guess I could give it 120VAC and see if it gets hot.

#30 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 04 May 2008 - 02:17 PM

So tonight I had some spare time and I decided to takle this fridge problem.

Although, for the past 10 days, the numbers have been fairly consistant (0,37F).

I pulled the power cord and took some measurements. I'm still getting around 32 ohms on the evap circuit, which is good. The thermistors were showing numbers in the 22K to 25K ohm range.

As I was puting the thermistor harness back in place that's when I notcied water in the drain pan. Which means the evaporator has been on at some point.... in the past day..... or two?

So at this point all is currently well?? Not sure what to do but sit around and wait for the fridge to mess up. I'm thinking of gettng a variable resistor (POT) and replace the evaporator thermistor, and then adjust the pot to see if/when the defrost cycle comes on. But then I'm assuming the fridge responds immediatley to a defrost value rather than to other factors like the compressor on, or ON-Delay of the defrost itself.

So I wait....


One odd thing, when I plugged the fridge back in, the numbers were 15F & 48F. Those numbers seem a little high for a frigde that was only off for maybe 1/2 hour? I wasn't concerned...and when I check the fridge another 1/2 hour later the numbers were 5F & 39F.


To Be Cont'd....

#31 rcdr

rcdr

    Samanera

  • Grasshoppah
  • Pip
  • 9 posts

Posted 18 June 2008 - 06:36 PM

Hi everyone, 

Am back again.  Finally got a chance to investigate the GE Profile fridge problem.  Was manually defrosting it. I'm seeing identical problems as Bob-tech has described. We have identical fridges and they appear to be built in the same month.

Can anyone confirm on the procedure for resolution?

1.  The freezing systems looks to be OK.  Evaporator has uniform frost and is basically all plugged up when the defrost problem occurs

2.  There are a number of thermistors in the freezer.  2 touching the evaporator, one on the right and the other (a round thermodisc) on the left.  The left one is in series with the defrost coil.  A 3rd is in the freezer wall and appears to be used to measure the freezer temperature.

3.  Like Bob-tech, I've measured the resistance of left thermistor in series with the defrost coil (when disconnnected from the rest of the fridge at the plug). They measure about 31ohms at about 70F and below.   

Does this measurement eliminate the left thermistor and defrost coil from being the problem?  The coil conductor so therefore will heat up. 

Regus_Patoff:  You've pointed to the comment in the service manual

[align=left]"The defrost heater is controlled by the evaporator thermistor and normally turns off at 70°F. If the evaporator thermistor fails, the evaporator thermostat will turn off the defrost heater at 140°F and will reset at 110°F."[/align]
[align=left]  Do I need to still check the left thermistor/thermodisc at different temperatures?[/align]
[align=left]4.  What does the right thermistor do?  Do I need to check it across various temperatures (Unfortunately, I have to cut the wire to check it) or do I simply assume its the control board?  [/align]
[align=left] [/align]
[align=left]Thanks.[/align]


#32 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 19 June 2008 - 12:27 AM

[user=33137]rcdr[/user] wrote:

... 3.  Like Bob-tech, I've measured the resistance of left thermistor in series with the defrost coil (when disconnnected from the rest of the fridge at the plug). They measure about 31ohms at about 70F and below.   

Does this measurement eliminate the left thermistor and defrost coil from being the problem?  

Yes



[user=33137]rcdr[/user] wrote:

... Regus_Patoff:  You've pointed to the comment in the service manual


[align=left]"The defrost heater is controlled by the evaporator thermistor and normally turns off at 70°F. If the evaporator thermistor fails, the evaporator thermostat will turn off the defrost heater at 140°F and will reset at 110°F."[/align]
[align=left]Do I need to still check the left thermistor/thermodisc at different temperatures?

4.  What does the right thermistor do?  Do I need to check it across various temperatures (Unfortunately, I have to cut the wire to check it) or do I simply assume its the control board? 

[/align]
[align=left]Thanks.
[/align]


The left Thermodisc is mechanical, and if it opens at 140F & above, and closed at 110F and below. It's used to stop the Defrost Heater if the Thermister/Controller circuit fails.

The right Thermister is variable and is sensed by the Controller to normally turn off the Defrost Heaterat 70F.

I don't know the resistance values, yet, but the Controller may think the Thermister IS over 70F and stop the Defrost Heater.
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#33 Poobah

Poobah

    Sensei

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,485 posts

Posted 19 June 2008 - 02:19 AM

this link (pic in the middle of the page) will give you the schematic for the motherboard and towards the bottom right side you will see the values and the temps the thermistors should be at....I will say again as I do on all these GE boxes don't put alot of faith in these thermistors, I have had them show to be good and flake out after going into defrost after 10-15 seconds....I automatically change the evaporator thermistor when doing a heater replacement or board swap (although it took me getting burnt twice to learn this valuable lesson)...good luck
This is the DAY that the LORD has made, REJOICE and be glad in it.....

#34 rcdr

rcdr

    Samanera

  • Grasshoppah
  • Pip
  • 9 posts

Posted 19 June 2008 - 03:13 AM

Hi RegUS_PatOff and Poobah,

Thanks for both of your clarification and advice.  I will proceed as follows:

1.  Replace the right Thermistor that is strapped to the right part of the evaporator

2.  If the above fails to fix the GE Profile fridge defrost problem, I'll replace the main board

3.  I'll report back once I've done the above and hopefully won't have to stay up until 2AM with my fridge again.

 

Thanks. 

#35 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 21 June 2008 - 06:08 AM

If the situation calls for a focred defrost, here is what I have done in the past.
1. unplug power to the fridge.
2. open the necessary panels.
3. check the resistance of the deforst circuit.

The resistance is measured between NEUTRAL (Blue wire) and the Defrost circuit (Brown wire).

The defrost circuit should be around 30 ohms. (Fridge still unpluged!)
If you do not get 30 ohms, but are reading infinite ohms - open circuit... then,
(a) The heater element has failed (Open circuit)
(B) The thermo disc is open circuit
© some part of the harness is open circuit

Once you have verified a value on the heater element (deforst circuit) to be around 30 ohms, then you can proceed to powering up the element and defrost the evaporator.

With the fridge still unplugged!
Set your meter to A/C amps and connect it in series wth the power line and the defrost line. See photos.
When you have everything safe and secure, plug the fridge in.
Your meter should instantly show a current value ranging from 3.6 to 4amps.
If it doesn't, unplug the fridge and check your connections!!!

Ensure the meter is on "A/C" amps.
Ensure the fuse inside the meter is good!


When defrosting I like to pull the evaporator drain line out from it's catch basin and place it something easier to dump the water out of.

I usually run the deforst cycle for about 20-25minutes.
I usually monitor the water flow out of the evaporator line.
When the defrosting first begins everything will be quiet for about 2 minutes. Then you should hear cracking, or water dripping, then the flow of water will come out the evaporator line.

If after 5-6 minutes you don't see water, then you may need to stop things and check on things from inside the freezer. The evap drain line may be clogged.

To do this forced defrost, you don't have to use a meter to measure the current. You could just jumper the Brown and yellow wires, but the meter gives the best indication of the what the element is doing.

How long to defrost???
Depends.
I usually stop after the water starts to slow down in flow, form the evap line.
If your thermodisc is working properly, then it will shut this circuit off once the evaporator itself reaches a warm temp. I never saw this happen...maybe I didn't run long enough.

Which is another good reason to use the meter.
If you find the defrost circuit shutting itself off early, then maybe your thermodisc is to blame for your defrost issues.

Defrosting will very from fridge to fridge, owner to owner...
I had company staying with me for a week and so the fridge got a few more open & closes. A forced defrost at that time pulled out 6 cups of water.

Here are some helpfull photos.
Note: I've spoken with others who have the same fridge, and they have the same wire colors. But you should check your wire connections and use mine as a reference!

Posted Image


Posted Image


Posted Image

#36 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 28 June 2008 - 04:32 PM

I finally got around to changing my thermistors.
1. On the evaporator, tie wrapped to the coil.
2. One in the freezer, right side wall.
3. One in the fridge, Ceiling, back-center.

The evaporator thermistor requires the most work to get to, but it's the easiest to work with. The one in the freezer and fridge don't have much wire room to work with.

This job is a little time consuming, but it's fairly easy. All you are doing is getting to the thermistors, cutting out the old and puting in the new.
Note: Thermistors are not polarized....so you can't hook them up backwards.

I strongly recomend soldering in your new thermistors.
I also recomend using heatshrink. Don't use black tape.
For each of my thermistors, I soldered each connection, then I covered the solder joints in RTV. Then I covered each connection with heatshrink. If you go the route of changing these thermistors, you must make a solid connection, and you must secure it. If you don't, then over time the connection will corroid and cause the main board to read incorrect values.

The connetctions for the freezer and fridge thermistor are tight because very little wire length is given to you. I see in the GE technical pdf they use marrets for this service. All I can say is....... good luck. Those marrets better be tiny. Besides... I would never use marrets in a situation like this.
 
When soldering in the thermistors, make sure the fridge is not plugged in.
Most soldering iron tips are earth grounded!

I also recomend that you test your new thermistors before installing them.
You can do this by placing them in a large glass filled with as much ice and water as possible. This will ensure the closest temperature reference at 0oC/32F.
Let the thermistors sit in the ice water for a good 5-10minutes.
Ensure they are well seated amongst the ice and water.
Then measure the resistance of each thermistor while they are sitting in the ice water.
You should be reading in the range of 14K-15Kohm.

I'll come back and report the status of my fridge when it's been enough of a testing period.

I took a picture of an old and new thermistor to show the difference in body.
In an earlier post in this thread, Jeff indicated that the bullet or rounded end shaped thermistors were problematic. I had the bullet shaped thermistors, so I changed out for the new flat end style.

Here are the pics....


Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

#37 rcdr

rcdr

    Samanera

  • Grasshoppah
  • Pip
  • 9 posts

Posted 02 August 2008 - 04:23 AM

Thanks everyone for the help and their advice with the my original GE Profile Fridge posting. Thanks to Bob-tech (with the same fridge and similar defrost problem to mine) for all of his investigations and detailed picture postings.

Looks like my fridge has been fixed.  Did all of the checks.  The 3 thermistors, heater coil and associated cutoff thermistor were all working fine (through multiple occurances of the problem).  Was waiting for the problem to occur again.  Just plunked in a replacement control board and everything is back to normal after one of its defrost cycles.

Thanks again.  Now back to the summer....

 

 

 

#38 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 02 August 2008 - 05:24 PM

Nice to hear...:D

#39 sunnyappli02

sunnyappli02

    Unsui

  • Grasshoppah
  • Pip
  • 1 posts

Posted 02 April 2009 - 09:44 AM

Thanks for the thermistor info. My question pertains to soldering the ones with really short leads, whether you had to deal with too much heat transferring into the thermistor while soldering, so that they would tweak and not work right. Are they reading accurately, as far as you can tell?

I have a PDS22MBW, about 2 years old with a bad board WR55X10416. In the process of replacing with a WR55X10656.

Ran some of the tests in the discussion.

Maybe I missed that part of the discussion, but here's another way I found to force defrost from the temperature control strip located in the refrigerator. I don't know all the models that this works on. My control strip has 5 buttons, from left to right it's (1)FREEZER TEMP COLDER (2)FREEZER TEMP WARMER (3)REFRIGERATOR TEMP COLDER (4)REFRIGERATOR TEMP WARMER (5)TURBOCOOL

Here's the sequence:

1. Press and hold the 4 buttons COLDER WARMER COLDER WARMER until the readouts start to blink - about 3 seconds. When first depressed simultaneously, there's a series of beeps.

2. The readouts will blink 0 and 0.

3. WHILE THEY ARE BLINKING ZERO'S, press FREEZER WARMER to read 1 and REFRIGERATOR WARMER to read 4.

4. Immediately press TURBOCOOL.

The defrost cycle should start and run for 20 or 30 minutes, something like that.

Note: this works on mine, even with a bad board.

One thing I noted was that in testing the defrost circuit from the back for resistance (blue wire to brown wire on mine) if the reading is open circuit it doesn't mean a bad circuit - you might happen to test when the thermodisc is open.

#40 Bob-tech

Bob-tech

    Yamabushi

  • Appliantologist
  • PipPip
  • 62 posts
  • Location: USA
  • Flavorite Brew:Coke

Posted 04 April 2009 - 01:35 PM

When I soldered mine in I prepped them first.
I stripped the wires about an 1/8" and tinned them.I slid on the heat shrink line everything up and soldered the wires togther. There is very little heat here, especially if the right level of heat and good solder i sbeing used.

When you say you are testing the "defrost circuit from the back for resistance", are you refering to heater element? If so, from what I understand, the heater element resistance should be present when the thermodisc is closed.
The thermodisc is closed when "things" haven't warmed up.
When things get too warm, the disc opens and shuts off the heater.
But thats how it is on my fridge.... which is all I'm familiar with.
(Don't have the TurboCool on my fridge)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics