Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***CLICK HERE AND READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
csebes

Maytag Neptune keeps spinning

8 posts in this topic

We have a Maytag Neptune MAH3000AWW that will not stop doing its short back-and-forth spins at the end of the wash cycle. We have to unplug the washer for about 5 or 10 minutes or so. At that point it seems that it resets and the door unlocks.

I replaced the timer thinking that was the problem, but to no avail. Still doing it. Is it the computer board on the back of the control panel that's fried?

Thanks, man.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

[align=left]from the service manual:[/align]

[align=left]ContinuesTo Tumble After The Wash Cycle Is Finished:[/align]

[align=left]Check for a stuck button on the door lock enable switch in the door lock mechanism. You can verify this at the machine control board by checking for continuity across P3(7)/YL 36 to P3(1)/RD23. If the door is unlocked and there is continuity, the switch button is stuck.[/align]

[align=left]At the end of the wash cycle, the machine control monitors the door lock enable switch for disengagement. If the switch is stuck, the washer will continue to tumble till the door unlocks, even though the door is actually unlocked.[/align]

Replace the door lock mechanism.

MAH3000AWW Service Manual

Share this post


Link to post
Share on other sites

I know the door remains locked. I tried to pull on it to see if it would open, but it's definitley locked, as the light indicates. I'll check continuity.

I guess the unplugging and waiting thing is a fail-safe of some sort? I have to unplug it, wait for it to unlock, then I can start a new load as usual.

I'll let you know what I find out. Thanks much.

Share this post


Link to post
Share on other sites

If the door remains locked at the end of the cycle, you will want to check and see if your board is continuing to put power down to the wax motor on the brown wire.  If the spin enable switch is shorted, the door will unlock and the lock light will go out, but the unit will tumble until the door is opened which causes the line relay to drop out.  Has anyone worked on this unit other then you recently?  I've had miss-wires cause the same scenario.  If you do not have a meter to check for L1 out of your board, visually inspect the board for any burnt resistors or burnt traces.  Concentrate on the left side of the board if you are looking at it from the front.  If there is a burn mark, it will be by the wire that supplies voltage to the wax motor.

Share this post


Link to post
Share on other sites

I tested for continuity after a wash cycle. I unplugged and disassembled, which took about 10 minutes because the bulb in my tester was burned out and had to find a replacement. This gave the washer plenty of time to unlock the door. So I hope this didn't screw up my results.

After confirming that the tester works, I followed your suggestion: there is no continuity between P3/7 and P3/1. What does this mean?

I didn't see any burnt resistors, but I wasn't checking that closely. I'll try again.

Thanks much.

Share this post


Link to post
Share on other sites

Approximately 5 minutes into the wash cycle your board sends out L1 on the brown 14 wire to your wax motor to lock your door.  At the end of the cycle, all your timer cams open which tells the board to stop sending the L1 to your wax motor.  Does your unit advance into the next cycle or does it stay at the off position indefinitely, tumbling back and forth with the door locked?  If it does not advance, then it is a pretty good bet that the timer cams have done there job and opened up.  If you let the unit go to off, and let it sit there for 5 minutes or so, you will want to test the Brown 14 wire to a neutral.  If you read 120VAC which I believe you will, then the board is not stopping the signal and the board will be bad if the checks below turn out fine.  Again, are we sure there are no miss-wires at the door lock assembly, wax motor, both switches, light, etc.  Also check your push to start switch.  You have power to it and it is a momentary switch, should only have continuity through it when you push it closed.  If you are shorted gray to black, you could have this scenario. Switch should open up both contacts (Gray to Black, Gray to Red) as soon as it is released.  You will not be shorted gray to red because the unit will only run 10 seconds that way.     

Share this post


Link to post
Share on other sites

So I see this is something I have to do with the unit plugged in. I'll also have to pick up a voltmeter since all I have is a basic continuity tester that turns a light on if there is continuity.

As for the way things work now, the dial goes around as the wash cycle progresses, and functions as it has since we got it about 4 years ago (second hand). When it gets to either of the OFF positions, that's when it continues to do it's back and forth tumble thing. I've even replaced the timer/dial unit and it continues to exhibit the same behavior. It's only after I unplug the washer and wait that five minutes that the door unlocks. I've tried plugging it back in only a minute after unplugging it and the door is still locked. It has to be the five or so minutes. I have to do this every time.

Share this post


Link to post
Share on other sites

Hey, all. Just wanted to update you on my washer problem. I found a replacement board on ebay for $85. Put it in and it works like a charm. To me this was worth it. I saved a lot of time by just replacing the whole thing than trying to figure out what circuit was bad, order a new one, replace the old one, test it, hope it worked...

Thanks for the help.

Happily washing again.

Share this post


Link to post
Share on other sites