Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

paul woolley

fisher and Paykel

3 posts in this topic

Model GW708U

unit pump starting and not draining, pump starts then stops(at rince cycle)  slight burning smell  from suds pump 4 ohms  resistance  measured  pulled out motor control board  and replaced ,now will not start up no lights  have i blown the touch pad how do i check and see if  eiter Motor control panel  or touch pad is blown???? I have purchased a new Motor Control board too nervous to connect it  can i do more damage

Rgds Paul

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Paul,  looks like you have a phase 4 unit.  I don't know how far you are into this but on that model there is a mode in the motor controller where it can shut down.  This can be caused by the thermal trip on the pump.  If this occurs the module will not restart unless the power is turned off at the wall for at least 90 seconds. Try that first.  The color of the motor controller identifies what phase you have...phase 4 should be yellow.  If you succeed in getting the power back,  Press the wash temp down button and the power button together...you should enter diag mode.  Then push the regular cycle button,  this will turn the pump on or off to test it.  Hope this helps you man...Ron

Share this post


Link to post
Share on other sites

Thanks Ron it ended up being a burnt out pump  and a blown board i replaced and all going well now   after $198 for controller and $74 for pump Thanks again

Rgds Paul

Share this post


Link to post
Share on other sites