Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

display 000 on ge profile arctic fridge


  • Please log in to reply
9 replies to this topic

#1 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 03 October 2009 - 11:00 PM

I replaced teh muthaboard on the fridge because a repairman diagnosed it as bad. Now the display does not work at all - except it flashes 000 for a few seconds when various control buttons are pushed. I too am seeking a service manual to assist in diagnostics.

thank you

Welborn

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 03 October 2009 - 11:03 PM

model number ?
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#3 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 03 October 2009 - 11:08 PM

MODEL# PSC23PSSA SS

GE PROFILE ARCTIC SIDE BY SIDE FRIDGE

EVERYTHING SOUNDS GOOD.
FAN RUNNING AND FRIDGE ON.
BUT THE DISPLAYS ARE BLANK. WHEN I CLICK A TEM BUTTON 000 SHOWS UP AND BLINKS.
THEN IT GOES BLACK AGAIN.
I GOT A TEMP READ OUT ONCE BRIEFLY AND THEN IT WENT BLACK AGAIN.
THAT ONLY HAPPENED ONCE.

PROBLEM  WITH THE FRIGE WAS THAT IT WAS NOT STAYING COLD.
DEFROSTING ON OCCASION AND FORMING ICICLES HANGING FROM THE ICE MAKER ICE HOLDER.



THANKS!!

#4 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 04 October 2009 - 12:09 AM

link PM'd
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#5 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 04 October 2009 - 08:36 PM

Hi I'm back.
I ran the test on the system.
One area failed.

03 - Temperature control panel to
dispenser board communication

FAILED

What does this mean and how can I fix it.

The manual told me how to perform the test but I haven't been able to find the area that addresses this problem.  Still looking.
Also I bought a new motherboard I think I got it from you.
Why wen I installed it did it show blinking 000?
I was not able to get it into any testing modes at all and unplugging the machine and replugging didn't help. Just curious. Worried I may have a wrong part.

Thanks!

Welborn

#6 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 04 October 2009 - 08:47 PM

Also when I lick the Turbo Cool button It gives me a strange symbol.
The readout looks like this: Ec except that the big E is missing it's top horizontal line.
Could this be related? What does it mean?

Thanks!!
I really appreciate the help.

Welborn

#7 kdog

kdog

    RoughShod

  • Academy Fellow
  • PipPipPipPipPip
  • 7,465 posts
  • Location: Canada
  • Flavorite Brew:Dickens Cider

Posted 13 October 2009 - 07:21 PM

tc = turbo cool, the display board is powered via the motherboard, the harness running to the display panel conveniently has some test points in the wires near the muthaboard. There are 3 wires and should be 2 d.c. circuits of approx 12v
Help us keep the lights on: buy appliance parts here ==> http://repairclinic.com

For service manuals and lots of other goodies, become an Apprentice ==> Apprenticeship

#8 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 14 October 2009 - 09:08 AM

Thanks for the reply. I think it is the motherboard and I apparently purchased the wrong one.
The readout is supposedly correct and stands for Tubo Cool.
I'll try the new motherboard tonight.
I'll post the outcome.

Thanks!!

#9 FERRENE

FERRENE

    Samanera

  • Grasshoppah
  • Pip
  • 6 posts

Posted 15 October 2009 - 08:42 PM

ok here goes!

I replaced my old Mothaboard with the new one.
Everything seems to be working fine.
However my old Mothaboard seemed to be working fine as well and we were having some defrosting problems.
I was concerned that everything was running fine so I ran the diagnostic. The fridge passed on everything accept 03.
It failed 03 the mothaboard communication with dispenser board. I got this fail with the old mothaboard as well.
Does it really matter? Is that what has been effecting the defrost control? Is it possible that by replacing the mothaboard with the new one that I fixed the defrosting problem but the 03 problem will persist?
Just trying to figure it out. Thanks!

#10 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 15 October 2009 - 09:56 PM

could be a bad Freezer Evaporator Sensor (Thermistor) ..

they tend to go bad

your Fridge uses (3) others in the Fresh Food air-flow areas ...

WR55X10025

click on picture
Posted Image
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics