Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

dave42

Jacuzzi Z112

4 posts in this topic

Request for Jacuzzi Z112 service manual

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Can't find a manual, but may be able to help. What kind of problem are you having?

Share this post


Link to post
Share on other sites

We had a problem that the pump only runs on low speed. The pump/motor was replaced and then the switch/sensor that is attached to heater was replaced. Seemed to be working fine, then after 2 days, the same problem recurred.

When tub is plugged in (110 V), the pump/jets run at low speed, and heater light is steady red. When we try to increase speed, the motor makes a humming sound, and the light on the GFCI plug goes off momentarily. The pump then continues to run at low speed. The circuitboard was replaced about 2 yrs ago. We noticed some tarnish on the contacts of the power plug and cleaned that off, but that did not help. Thanks.

Share this post


Link to post
Share on other sites

I don't know if this info will help, but it's all I could find.

Jacuzzi Spa Electronic Control System Troubleshooting Guide G647000 7-95.pdf

Jacuzzi Electrical Section 7348000E 4-97.pdf

 

 

Share this post


Link to post
Share on other sites