Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

delta0770

Evaporator fan runs during defrost, but not when it should

5 posts in this topic

I am working on a Magic chef top freezer refrigerator, Model # RB15EA2AF.  When I removed the back panel the evaporator fan is not running.  When I turn the defrost timer to defrost mode the fan kicks on when the timer is turned out of defrost mode the fan kicks off.  I have replaced the fan, the termination switch, and the defrost timer with no success.  Anyone have any ideas before I take a baseball bat to this thing!!!!!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

what was the original complaint?

Share this post


Link to post
Share on other sites

The fridge wasn't getting cold, and the freezer is not cold enough.  But I am sure that is because the fan is not blowing.

Share this post


Link to post
Share on other sites

Need to see your wiring diagram -- something got miswired somewhere. You can post it here as an attachment. If you can't scan, you can fax it to me at 775-416-4449.

Share this post


Link to post
Share on other sites

Someone has ripped the schematic off the back of the fridge, and there isn't another one anywhere else on the fridge.  Do you know of anywhere online that I can find the schematic for that fridge?

Share this post


Link to post
Share on other sites