Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Locust

GE Dishwasher Control Panel

7 posts in this topic

I believe the Model is GSD4030z07.

That said, it is a GE Profile Dishwasher, with electronic control panel and dials.

The original panel is faulty and won't always advance the cycles.

GE Tech ordered the part under warranty, but labor is not covered.

Hey, I'm a computer dork by trade and am capable of removing 7 screws and replacing the parts myself once they arrived at my door.

Easy.   Took all of 20 minutes.

The problem:

It won't work.  Apparently there is some sort of programming that needs to occur for it to work. 

The questions:

1)  Is the tech required to perform this?  (There is a port for possible laptop connection).

2)  If it is simply sequence of buttons...What is the sequence, oh Samurai?

3)  Yea, I got the part free, but the labor isn't...unless the labor is mine...I am not employed, :(, so  I can't afford the minimum 2 hour charge, if I can help it...

4) ... But I can afford to contribute to your beer fund.  :cheers:

:phone:GE is of course no help.  But have I challenged the Samurai?

Enough...can youse help me?

 

 

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

No programming required, it's plug n' play. :bart:

Couldn't get the model number to work-- re-check it.

Share this post


Link to post
Share on other sites

Alright, I've got more input for you.

GSD4030 is the part number by removing the z07 I actually found an online manual @ GEappliances.com.

With the new part in, the "clean" indicator flashes.  GE, of course, says call for service. 

I've tried reset, repower, and the "Any" key, all with no luck.

Kids did the dishwasher by hand, but not sure if THAT will last through the weekend.

Hope your Friday is better than mine and your beer colder.

 

 

Share this post


Link to post
Share on other sites

I can only think of three possibilities:

1. the lid switch is bad or one of its wires got disconnected

2. you fried the control board when you were installing it (they are static sensitive, as you probably knew)

3. there was something else wrong with it all along.

Can you find the tech sheet on the dishwasher?  Usually lives behind the kick plate.  Post it here or fax it to me:  775-416-4449.

Share this post


Link to post
Share on other sites

To find the tech sheet.

    Take out the 4 1/4 inch screws that hold the two parts of the service panel in place.  Lay down on the floor on your left side and look under the dishwasher.  You'll notice there is a piece of sheet metal lining the underside of the tub.

    The tech sheet is tucked between the tub and the sheet metal on the right side of the machine toward the front.  Grab the sheet with your left hand.

     What was the original complaint?  What's it doing now?  The newer style door switch is kinda flimsy.  Did you disturb it when you removed that board?

Share this post


Link to post
Share on other sites

:banana::banana::banana::banana::banana:

 

What can I say, My weekend has been made.

Found the tech sheet right where the Jedi Master indicated.

Reviewed the wiring diags to confirm the model...etc...

Turns out a jumper needed to be placed between ports 1 and 6 in order to identify the model as 4000 series...took that off the old control panel (:beating:...duh...shoulda looked at that in the first place.

Tech sheet also instructed on initiating test sequence, which then executed flawlessly.

Running through normal cycle now, but if youse all don't hear from me, it worked as I just described.

:pint:Beer money on its way to Samurai...looking forward to my free DVD. 

Between the starter in my 97 Nissan and now this, I've saved nearly $300 in labor this week.   (less Samurai's modest fee, natch).

Thanks guys.

Locust bows to you both.

Share this post


Link to post
Share on other sites

Woo-HOO!  Thanks for the follow-up report... AND the brewski's!  :rocker: :pint:

The homewiring DVD is being transported to you as we speak!  :ufo: 

Share this post


Link to post
Share on other sites