Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

JennAir wall oven W30400W - perplexing problem(s)


  • Please log in to reply
13 replies to this topic

#1 CraziOne

CraziOne

    Samanera

  • Grasshoppah
  • Pip
  • 7 posts

Posted 30 July 2010 - 05:33 AM

Konnichiwa great Sensei,

I have a very perplexing set of problems with my electric JennAir wall oven (model # W30400W).  It is about 12 yrs old.  I have read the FAQs and many, many forum posts and still know not which way to turn.  Perhaps you and/or your great masters can help me?  Without being too detailed, it will still take some time to explain the history, symptoms, and what I've tried.  So go grab some saki or your favorite brew, sit back, and read on ...

About two years ago, I replaced the ECR because of a dim display.  A few months later, we tried to use convection bake, but the fan never turned on (not sure when it went kaputz, as we seldom ever use convection).  No worry - since we seldom use it, we can live without it.

Fast forward to last week.  Set oven to bake ... no heat.  Tried broil ... no heat.  Ohmed the elements - around 18 ohms each - good.  Ohmed temperature probe - around 1090 ohms - good.  Ohmed the hi temp limit switch - 0 ohms - good.  Checked L1 & L2 - 120 Vac to ground on each, 240 Vac across them.  Removed relay board.  Visual inspection yielded burned traces between the convection bake relay and wire terminal connectors.  Aha! that's why the fan stopped working!  Perhaps it's related to the recent heating problem?  Even after all this time?  But what caused the traces to burn out?  Must be a short.  Further investigation revealed the conv bake wire was broken where it passed through the rear wall.  Apparently the wire had rubbed against the opening, chaffng the insulation resulting in a short which burned out the traces.  The wire was burned into at that point also.

Remedy: I stripped and crimped the broken wire back together and soldered heavy gauge wire over the burned traces.  Re-assembled everything and powered up.  So far, so good.  Set it to bake.  Within seconds, error code F5 appeared (that's new).  Same with broil.  Removed power and double-checked the wiring.  Triple-checked it.  Restored power, tried bake - same error code. 

I removed the convection motor and ohmed it - infinite betwen conv bake and neutral, infinite between conv roast and neutral.  Motor is burned out?  Could THAT cause the F5?  The service manual says the following about F5:

F5 - Power to element relays disabled in cook mode.

1) Intermittent sensor or wire harness connection

2) Intermittent contact on PRB

So could the ERC or PRB be disabling the element relays because of the bad motor?  How?  I see no sensors to detect if that motor is bad.  But it could be a bad PRB.  I've removed and re-installed the PRB many time throughout this, so I doubt it's a bad connection - I've ohmed, wiggled, etc. the wires and connectors.  Oh, and note that I never hear the element relays click on.  But I can hear the cooling fan relay and light relay click on/off.  I've run the power-up diagnostics where you can hold a key to turn relays on.  The element relays don't turn on.  All others do.  Wait - I can't remember if the convection relays worked.  I'll have to check that later.

Would you suggest replacing the motor first?  The PRB first?  Or can you suggest a step I've missed to narrow it down further?


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 30 July 2010 - 06:37 AM

[user=69264]CraziOne[/user] wrote:

...  Ohmed temperature probe - around 1090 ohms - good... 

just the Probe ?

or also the (2) Oven Sensors ?

.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#3 CraziOne

CraziOne

    Samanera

  • Grasshoppah
  • Pip
  • 7 posts

Posted 30 July 2010 - 08:07 AM

The built-in temperature sensor is what I referred to as the probe - it should read 1000-1100 ohms at room temps.  It read 1090.  The only other sensor I see is a high limit cutoff switch that should be closed at room temps.  It is.  There's the meat probe, but it's not plugged in - seldom is.  I cannot see any other sensor or probe on the oven or the diagram.  Did I miss one?

#4 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 30 July 2010 - 10:36 AM

I must have been looking at the wrong wiring diagram ...

You'd have to test continuity to see if the Bake & Broil Elements are actually connected to L1.

And continuity from L2 to the Oven Controller.

.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#5 CraziOne

CraziOne

    Samanera

  • Grasshoppah
  • Pip
  • 7 posts

Posted 30 July 2010 - 12:16 PM

I pulled the black wire from the L1 tab on the PRB and probed on the wire.  I did the same with the BAKE wire.  So I tested continuity from the wire terminals through the wires to the element - about 18 ohms.  I did the same with the BROIL wire - also about 18 ohms.  So for each element, I have continuity to it, through it, and back again - basically from the PRB to and thru each element..

With 240 Vac power on, I probed from the L2 tab on the PRB to GND - 120V.  From L1 tab to GND - 120V.  Redundant, but across L1 and L2 I read 240V.  The wire ends appear to be good and tight on the connectors.  So I believe the PRB is receiving both legs of 120V and neutral.

This makes the PRB suspect in my mind - especially as I said I cannot hear the bake or broil relays click in.  And when they're supposed to be clicked in, I read 0 V across the element that is on.

But the description of the F5 code makes me suspicious.  Is the PRB or maybe the ECR deliberately keeping those relays turned OFF for safety due to an as yet unknown problem?  Could the unknown problem actually be a burned out convection motor?


#6 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 30 July 2010 - 01:28 PM


no other burned traces on the board ?

Temperature Sensor ... 1000 OHMs
measured at the Controller ?


With the Oven turned OFF, check for 120v

from the Relay Board BAKE Terminal to chassis (GND)

from Relay Board BROIL Terminal to chassis (GND)

then with the Oven ON, check for voltage across the Relay Coils .. (it may be DC)

I'll try to find a schematic
 

http://www.partselect.com/Schematics/Maytag/49513.gif



.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#7 CraziOne

CraziOne

    Samanera

  • Grasshoppah
  • Pip
  • 7 posts

Posted 31 July 2010 - 11:40 AM

Temp sensor 1000 ohms was measured across the wires pulled off the PRB.  So the measurement included wiring.

With oven off, I do read 120V from BAKE terminal to GND and from BROIL terminal to ground.

I had to solder some wires to the coils' pads on the PCB to allow me to safely probe there.  With BAKE on, I read only 2.5-2.6 Vdc across that relay.  Same with the BROIL relay.  Those relays are Potter T90N1D12-12, which have 12V coils.  No wonder they aren't pulling in!  The coils read about 150 ohms as they should.  So it looks like I have a defective driver on the PRB.  Both relays are driven on one side by a common pair of transistors.  It could be one of those.  Next step is to decide whether to try to troubleshoot it or just buy a new one.  I could save $150 if I can fix it.

I remembered that I still have the old (original) ECR I replaced a couple years ago.  It works, it's just that the display grew dim.  I'm glad I kept it because I swapped it out and the oven behaved the same.  So that pretty much rules out the ECR as the culprit.

About the F5 error - I think it's an intermittent connector.  It miraculously went away once, then re-appeared again.  Wiggling the door switch harness seems to affect it.

So, all-in-all, this is what I'm leaning toward:

1) Burned out convection motor - either live with it or replace it.

2) Bad PRB,  - either troubleshoot it or replace it.

3) Loose wire harness - identify where contact is loose and repair or replace.

What do you think?  Does this sound reasonable?

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics