Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Begin your journey to appliance repair mastery…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
srp

my washing machine doesn't spin, makes loud sound

7 posts in this topic

My washing machine MODEL # LXR9245EQ2 doesn't spin, makes loud sound, I removed everything ( I mean direct drive with help of spanner wranch and then removed whole inner tub[basket])and tried to spin, now it doen't make sound and motor runs correctly, shaft spins correctly. Appriciate any help

Thanks

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Take a look at the drive block the spin basket was setting on top of, might be worn out inside sliding down the spin tube...

Share this post


Link to post
Share on other sites

does drive block means basket drive? holo tube? Can you please show me what is that part call or part#? Please. Thanks for your time

Share this post


Link to post
Share on other sites

[user=533]Pegi[/user] wrote:

Take a look at the drive block the spin basket was setting on top of, might be worn out inside sliding down the spin tube...

I forgot to mention you earlier, I already replaced new block drive, (I read somebodys problem, replied by you) still giving me load sound.

Share this post


Link to post
Share on other sites

Ok, the washer spins ok with the spin basket out but when it is in it does not spin and makes a loud sound??? Is this correct???  Did you see if the top of the basket drive assy the drive block sits on might be damaged???

Share this post


Link to post
Share on other sites

[user=533]Pegi[/user] wrote:

Ok, the washer spins ok with the spin basket out but when it is in it does not spin and makes a loud sound??? Is this correct???  Did you see if the top of the basket drive assy the drive block sits on might be damaged???

Yes thats correct, it spins ok with the basket out but when it is in it does not spin and makes loud sound.

If I see inside of basket drive assembly ( pipe like thing ) some thing like black rings doesn't look good. Thanks

Share this post


Link to post
Share on other sites

I tried to change whole basket drive assembly but getting same load sound. Can you please help me?

Share this post


Link to post
Share on other sites