Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Greg Muller

KitchenAid Dishwasher Model KUDI 01 TJBL 0

2 posts in this topic

After years of good service, my dishwasher developed a problem: it had no heat/drying cycle, the overall run times were greatly prolonged, the "water heating" light on the control panel was coming on for long periods, and the dishes were wet coming out of the dishwasher. Everything else worked, so I figured it was a bad heating element.

I replaced the heating element with the KitchenAid kit, which included a new electronic control component, no problems with the installation. I moved the ceramic block (thermal fuse?) from the old control board to the new control. I then started the dishwasher and it ran, initially all seemed fine, but the machine quit somewhere during this first run (sometime after the detergent was released) with a small amount of water remaining in the bottom of the tub.

Now, when I try to start the dishwasher, the control panel light (e.g. "normal cycle") comes on, then I push the "start" button and there is no action by the machine, and then the light goes out; machine doesn't start, nothing.

Any thoughts?

Thanks for your help.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Update:

I checked continuity on the thermal fuse, the door switch, and the overfill switch--all are fine.

The "cancel/drain" button works, runs the drain pump for about 2 minutes, then off. The rest of the cycle buttons still light up, do nothing, turn off.

I'm ready to call the repair service/price a new dishwasher.

Share this post


Link to post
Share on other sites