Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Lefthand50

KitchenAid icemaker not working; blinking red LED

15 posts in this topic

Greetings!  The icemaker on my kitchenAid icemaker stopped working about a week ago.  The model is a KitchenAid Superba (model #KSRG25FKWH15).

The "icemaker switch" is in the on position, but the red LED that is on the same panel is blinking.  Unfortunately, the manual doesn't cover this situation.

I saw this link http://fixitnow.com/2003/01/appliance-tip-of-day-no-ice-in-your.htm, but is doesn't reference what to do if the light is blinking?

I also saw this page - http://laminateflooring.oncloud8.com/archive.php/o_t__t_7081__icemaker-problem.html but no luck on the meaning of the red light.

This link was a little unnerving, as it seemed to indicate the entire door needed replacing..http://www.complaints.com/directory/2004/november/20/1.htm

What's the blinking LED mean?  Any suggestions on steps to troubleshoot this?  Much obliged for any assistance - thanks, Alex

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Thanks!  Is this any more complex than a normal circuit board?  Any soldering involved to remove and replace, or can I unscrew and "plug-in" the appropriate connectors?  From the picture and my examination of the fridge, it looks like the latte, but confirmation would be helpful.

thanks!

Share this post


Link to post
Share on other sites

Plug n' chug; no soldering.  Just unplug the fridge before starting work.

Share this post


Link to post
Share on other sites

Hello Samurai Repairman:

We saw an inquiry on the internet from a person asking for assistance with their KitchenAid Superba ice maker.  We have the same problem with ice not being produced.  Our KitchenAid is about 2-years old. 

The control panel is in the "on position" and the red-light on that panel is blinking.  I put my hand into the maker to see if there were any "stuck" cubes and found one cube located in the back of the "in-fill" trays but nothing appeared jammed.  Do I have the same need for a new optics emitter and receiver board?  If so, are they located behing the Control Panel and how much do they cost and do you supply them?  

I saw a complaint on the internet by another customer and she was told the problem involved faulty wiring in the freezer door?  But that doesn't sound probable.  Your response will be greatly appreciated. 

Share this post


Link to post
Share on other sites

I would be checking to see if the thru tube is clogged with ice first since only one cube is in the ice mold, that is a known problem with the IDI Systems..if so there is a heater kit that will need to be installed.

Share this post


Link to post
Share on other sites

To check the optics in the freezer open the freezer door, if the light repeatedly flashes twice followed by a 1 second pause then the light is blocked.  Close the emitter flapper and the light should stay on.  (Make sure there is nothing to block the path)  If this checks ok, than your problem is likely to lie within the ice maker.  Remove and turn ice maker towards you and remove the white cover.  You will see various terminals for testing.  Obtain a piece of solid 14 gauge wire about 3 inches long and strip 1 inch from both ends, then bend the wire into a "U" shape and insert the jumper into terminals "T" and "H".  Place icemaker back in freezer and close the freezer door.  After about 10 seconds open the freezer door and you should see the wheel begin to turn to initiate a harvest.  If this is the case than the emitter and receiver board a probably not at fault.  You can now remove the jumper wire and the ice maker should complete its cycle.  Make sure you have the icemaker installed properly or be prepared to catch the water from the fill tube.  Hope this helps as a start.

Share this post


Link to post
Share on other sites

I fix this problem by getting a hair dryer and thawing out the rubber fill tube,and the plastic piece directly below it( im guessing this is the fill sensor)

works for me every time

hope this saves people some money and aggravation

Share this post


Link to post
Share on other sites

hello all. I am having this same problem. I did find the filler tube was clogged and thawed it out with the hair dryer. I did closed the emitter flp and the blinking light stayed solid so I figured it was to be a clogged tube but still no ice after thawing it out. What else could my problem be or could it be that the tube it clogged further bag down the line?

-Rick

Share this post


Link to post
Share on other sites

It just started working. I reset the power on the unit and it started working but the light is still blinking. Am I ok?

Share this post


Link to post
Share on other sites

I have seen many of these that have a broken gear in the icemaker module. I don't know if it's a bad production run or what. I've been using alot of part #628366 the last few weeks. Sometines the gear is broke clean off, and sometimes it's just stripped off the plastic pegs that hold it on.

Nick

Share this post


Link to post
Share on other sites

WAIIIT!!!! before ordering parts!!!

take the grill off the bottom front. there should be 2 tech sheets, one at each corner of the grill itself. ones a wiring diagram and the other has test procedures for the optics.

the blinking has patterns (3 blinks and a pause for example)

some testing involves holding the door switch closed. read carefully.

they optics are a very common failure but another common problem when the complaint is no ice production is the water line supplying the ice maker is frozen.

the water line runs along the ceiling of the freezer and then out the back down to the valve. there is a kit where you get a new water line and a heater to wrap around it.

Share this post


Link to post
Share on other sites

The light is blinking but it is making ice and working perfect. I'll leave it alone I guess.

Share this post


Link to post
Share on other sites

Thanks for this awesome site! :D  This forum helped me fix the ice maker on my Kitcheaid Superba side-by-side refrigerator (model KSRG25FKSS).  It's just a year old and I couldn't figure out why the ice maker stopped working. 

I had just replaced the water filter and nothing was amiss until I noticed water in the grout of the tile coming from under the fridge.  I pulled the fridge from the wall and found that water had leaked all under the fridge.  Not a lot, but enough for concern.  No damage to the water line or connections and I was stumped because after changing the filter, the water dispenser on the door worked fine.  I decided to keep an eye on the leaky water and found that it was wet only occaisionally.  Turns out that when the ice maker was periodically attempting to draw water, the ice blockage in the feeder tube was forcing it back down into the filter and causing it to leak all over the floor. 

Solution:  Took the advice of the others on this page and thawed it with a hair dryer.  I could feel the ice in the tube and kept trying to work it back and forth until I felt the ice actually crack and break up.  To my amazement, it slid right out.  Within minutes, the ice maker drew water and the leak did not return!

The hair dryer fix only took 5 minutes and it saved me a $55 service call (Sears) plus labor, not to mention the time it would require me to miss work and wait for the tech to show up between 8am and the time of my death.   :X

Great site, I'll check here first for all my appliance issues.  Thanks again!!

Share this post


Link to post
Share on other sites