Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

PRCNC

Frigidaire FWTBB30DS0 front load won't start

13 posts in this topic

My Frigidaire FWTBB30DS0 front load won't start when you press START. All the other buttons/options work. Please help! Thanks!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Press START But Nothing Happens

After selecting a cycle, there is a 4-5 second delay before water fill or start of operation.

If the washer fails to start after 5 seconds after selecting a cycle and pressing Start,

BEFORE PROCEEDING FURTHER, disconnect power cord from the outlet for a couple seconds and re-connect.

This will clear the board if it was inadvertently set to "Demo" mode.

(Demo does not allow unit to operate when pressing start).

Share this post


Link to post
Share on other sites

Unplugging doesn't change/fix the issue. The board will display the cycle selected from before removing the plug from the outlet, even if left unplugged for a long time. If I remember correctly pressing START would lock the door (audible click), this does not happen either. (The board will display the do code if the dispenser is open.)

Other suggestions/troubleshooting?

Thanks!

Share this post


Link to post
Share on other sites

Door not locking-- door lock assembly may not be getting voltage (less common) or need a new door lock assembly (very common).

Share this post


Link to post
Share on other sites

Dispenser Drawer closed ?

and Drawer Magnet in-place

(bottom front of Drawer)

00561829.jpg

Share this post


Link to post
Share on other sites

The door is closed and the do code on the board goes off when it's closed. The magnet is missing. Would the magnet being missing cause the machine to not start?

Share this post


Link to post
Share on other sites

Good call, Master Reginald! :)

Share this post


Link to post
Share on other sites

The door is closed and the do code on the board goes off when it's closed. The magnet is missing. Would the magnet being missing cause the machine to not start?

Does the magnet activate the REED SWITCH?

Share this post


Link to post
Share on other sites

OK, the magnet is on the dispenser drawer. Don't ask...

So I guess we're back to the door locking mechanism....

Share this post


Link to post
Share on other sites

Replacing the door locking mechanism did not fix the problem.

Any ideas? Thanks...

Share this post


Link to post
Share on other sites

May be a bad Start Switch (part of the Controller)

Membrane Keypad Test

To activate, unplug power cord and reconnect.

Press and hold TEMPS and STOP keypads simultaneously at least 2-3 seconds within 10 seconds of power up.

Test Sequence:

Press each keypad (CYCLES, TEMPS, SPEED, OPTIONS etc.) separately to verify each keypad functions and all the LEDs for the selection light up

Press START to verify Display readouts are functional

Share this post


Link to post
Share on other sites

Cycling through All of the buttons work, except the START button. Also, when you press and hold LOCK, it beeps, changes the display but doesn't lock the door.

Share this post


Link to post
Share on other sites

"Lock" only locks out the control, so that children cannot activate machine

Link to Control Board:

00915404.jpg

Share this post


Link to post
Share on other sites