Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
gtushim

WTW6400SW2 Cabrio Washer F50 error code

4 posts in this topic

It all started when i was hearing a "grinding sound" at the beginning of every rinse cycle. I took the washer apart and found the drain motor making the terrible racket and replaced it. I put the machine on a rinse and drain cycle and the and now that it has been replaced, the machine is still not draining. I then tried putting it on a wash cycle and I am now getting an F50 code. After reading some history of this washing machine, i went digging for part # and cost. Well i have found a control board (AP4360738) and a control-ELEC (AP3958445) both of which "sound" to be the right part. Can someone point me in the right direction. These are both rather expensive and I really only want to replace what is neccessary. Thank you in advance and I look forward to hearing from someone in the near future. Happy Easter!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Does the Drain Motor running, now?

Is it getting voltage ?

F50 (main) Motor Stalled

F then 50 flashes when the motor rotor position sensor (RPS) senses no rotation.

➔ Does basket turn freely? If not, make sure bottom shipping pack has been removed.

Determine cause of friction.

➔ If basket turns freely, see TEST #3, page 4.

For manuals and lots of other goodies,

become an Apprentice==> http://appliantology.org/apprentice/

Share this post


Link to post
Share on other sites

When you replaced the drain pump - any chance you pinched/disconnected or otherwise moved any other wires underneath? Because F50 started when you replaced the drain pump, you can pretty much be sure that it is not a bad board. More likely that a wire to the RPS sensor was disconnected.

Because you had a busted pump, it might be best to pull the inner basket anyway just to make sure there are no more coins or bra wires ready to break your new pump. At the same time you will see if there is something caught between the tubs causing your F50 code.

Lift the main top (2 spring clips about 5" in from each side)

Pop the little cap off the center of the agitator

Remove the bolt

Remove the tub ring that is clipped onto the top of the outer basket (one hose connected on left rear)

Pull straight up on the inner basket till it slides up off the spline shaft

Remove the 2 1/4" screws from the white drain/recirculating pumps cover

Make sure there is nothing caught in that area

Reassemble.

Share this post


Link to post
Share on other sites

For future readers of this topic, part link for the RPS kit to fix the F50 error code ==> Rotor Position Sensor

Share this post


Link to post
Share on other sites