Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Maytag stove MGS5770ADW no spark on all 4 burners


  • Please log in to reply
2 replies to this topic

#1 ajanitor

ajanitor

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts

Posted 11 May 2011 - 02:19 PM

There is no clicking sound when the burner knob is turned to start position. The stove has power on the front display panel and the oven works. The burners light OK with a match. The spark was getting weak over the past few days. Please advise how I can test where the problem is; I am hoping this is a cleaning issue and don't want to pull the stove out from the wall to test / replace the spark module unless needed.

Any help/suggestion greatly appreciated. Thank you!

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,873 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 11 May 2011 - 04:04 PM

No spark on any burner =-= bad spark module. Come git you one... http://www.repaircli...mber=MGS5770ADW

#3 ajanitor

ajanitor

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts

Posted 23 May 2011 - 07:52 AM

I hate to disagree, but the symptoms are intermittent. It worked fine for the past two weeks, now, once again, no spark on all 4 burners but they lights with a match. Is there any way this could be related to a spill on one or more burners?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics