Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

manchmal

Frigidaire Front Load Washer FWT449GFS2

6 posts in this topic

Sensei,

I thought i had narrowed down the choices and i bought a new door latch assembly, installed it and it worked for about a month. (My washer was not agitating or spinning but would fill and drain and the timer would advance....aka: soggy clothes syndrome). I am not sure how to figure out electrical stuff so this was an 'educated' shot from internet research. Now the washer is back to where it was, no agitating or spinning. Is it the control board? On this machine it is a $350-$400 part....(ugh....) Of course there is no return for the door latch assembly....bought locally.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Of course there is no return for the door latch assembly....bought locally.

Let that be a lesson to you: always buy your parts through this website and get the peace of mind of a one year warranty!

There's a troubleshooting tech sheet inside the washer, remove the bottom kickplate to get it. There's a procedure in there to get you on the right track with this. Start with that and post your findings. I also have a troubleshooting flowchart on this page. Pay special attention to the note about the molex connector on the motor!

The fact that it worked for a month after replacing the door latch assy makes me suspect a wiring issue. Remove the wires and reseat them in the door latch.

Next, check the dispenser door magnet and reed switch. If the washer thinks the dispenser door is open, it won't run at all.

Share this post


Link to post
Share on other sites

Yes,....this is the tech sheet....I'm not sure what i'm supposed to be looking at....

Share this post


Link to post
Share on other sites

Ah. Husband took out door latch assembly and reconnected it. It worked....and then didn't. I don't think it's the dispenser door magnet and reed switch. The washer does go...it fills and drains but does not agitate or spin.

Share this post


Link to post
Share on other sites

... I also have a troubleshooting flowchart on this page. Pay special attention to the note about the molex connector on the motor!

Share this post


Link to post
Share on other sites