Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Begin your journey to appliance repair mastery...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Giznawz-old

Frigidaire/Electrolux Dishwasher M# FDB510LCB3

7 posts in this topic

Garbage disposal plug has been removed

Air gap thing is clear

Drain line is clear between air gap and disposal

Drain line is clear between impeller and air gap thing (confirmed using the Essential Lip Lock Maneuver)

Impeller is clear (Lip lock maneuver again)

Flap valve at impeller outlet looks good

I'd like to confirm the impeller works but don't know how.

What's next to check?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Does the Drain Pump run ?

Is it's Impeller OK on the Shaft ?

Share this post


Link to post
Share on other sites

I used the wrong words. I removed a Johnson SN-3125, which I called the impeller (Repair Clinic part #1378825). I confirmed that air moves through it when blown. I don't know how to confirm that it runs. I tried to take it apart to inspect the condition of its impeller but met with more resistance than I expected when trying to separate the motor from the impeller housing, so I stopped.

When the dishwasher is running and tries to drain, it makes a low pitched humming noise. It doesn't sound like water is moving at all. I wanted to look at the impeller in the pump to confirm whether it is jammed but was afraid of breaking the pump by prying it apart.

What should I do next? Thanks a lot!

Share this post


Link to post
Share on other sites

Regarding the impeller on the shaft: I am able to spin the impeller clockwise (when facing the pump inlet) but not ccw. What I can see of the impeller through the inlet and outlet appears to be sound. Should I try to open it up to see if something is in there?

Thanks!

Share this post


Link to post
Share on other sites

Has this worked OK up till now at this location ?

Make sure Pump is getting 120v AC

Disconnect the output Hose (into a bucket, or connect a longer hose)

Share this post


Link to post
Share on other sites

I confirmed that the drain pump is bad: I got the impeller housing off the pump, gave it 120v AC, and the impeller just quivers in place. Time for a new drain pump. Thanks!

Share this post


Link to post
Share on other sites