Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Heil Condensing Upflow Gas Furnace Model NUGK075AG02


  • Please log in to reply
3 replies to this topic

#1 Fixitman2

Fixitman2

    Unsui

  • Grasshoppah
  • Pip
  • 1 posts
  • Flavorite Brew:Iron City

Posted 15 August 2011 - 10:04 PM

When blower failed to run in "Fan Auto" or "Fan On" modes, I replaced the blower relay, and the AC ran normally for one month and then the relay failed again. I replaced the blower relay again, and the AC ran normally for two more months but failed again. What could be causing the blower relay to continue to fail?

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 16 August 2011 - 04:14 AM

How is it failing ?
Relay Contacts "burned" ?
Relay Coil "open" ?
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#3 ACtechGUY

ACtechGUY

    HAKUNA MATATA!!

  • Sublime Master of Appliantology
  • PipPipPip
  • 279 posts
  • Flavorite Brew:MMMM..ANY....BEEEER....

Posted 16 August 2011 - 06:17 AM

The correct relay is one rated for 12 amps at full load(FLA). Assuming you are using the right part , there is one reason for failure.
Relay
PART NUMBER: 90-340







Failing blower motor or failed capacitor . The motor is drawing more than the rated amps on the relay.



#4 Dan Webster

Dan Webster

    Paw Paw

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,320 posts
  • Location: USA
  • Flavorite Brew:Busch

Posted 16 August 2011 - 10:43 AM

What relay are you using?

"May the hinges of our friendship never grow rusty"
-old Irish saying

Buy me a Beer: http://web.me.com/ze...man18007260692/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics