Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Sign in to follow this  
Followers 0
jkilgore34

Samsung dmr78ahs dishwasher grinding noise and error code 9e

3 posts in this topic

dmr78ahs I'm wokring on this dishwasher. There is a grinding noise when first started up and after a minute or two I get 9e error code. I believe that means low water level. I took out and took apart the water level assembly and I didn't see any obstructions. the micro switch tested good. I took off the flow meter as well and took it apart and It looked good as well. I have been told those flow meters can go bad. Is there a way to test a flow meter? Where could the grinding noise be coming from? Drain pump maybe?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

<<<There is a grinding noise when first started up>>>

*************************

Many Samsung DMR57 & DMR78 dishwashers are known for developing a rattling/grinding noise during DRAIN MODE.

This is usually caused by a broken plastic mounting tab from the upper rack ADJUSTERS.

Each side of the upper rack has a tan/gray square RACK ADJUSTER---after a mounting tab (or 2) breaks off---this piece of plastic eventually ends up in the DRAIN PUMP HOUSING.

The DRAIN MOTOR should be removed to inspect for debris.

******************************

<<<after a minute or two I get 9e error code>>>

******************************

A normal amount of water in a DMR78 dishwasher would be---at about 1 inch past the HEATER SHIELD in the tub.

If you've tested the SWITCHES on the LOW LEVEL SENSOR---then they're not at fault.

Press the following buttons at the *same* time:

DELAY START--NORMAL--POWER(button)

The word "ALL" appears for 3 seconds followed by "t1"

(NOTE: Test #1 checks the functions of the INLET VALVE--FLOW METER--LOW LEVEL SENSOR)

Press the DELAY START button---the DRAIN MOTOR will run for 45 seconds. Then---water will enter the tub.

When the PULSE COUNT (on the display) reaches "660" or greater---press the NORMAL button four times.

A flashing "t5" will be displayed & water will drain for 30 seconds. After 30 seconds---the "t5" will stop flashing.

Press the NORMAL button again---"t6" will be displayed. The word "OFF" should appear in the control panel display---indicating that the LOW LEVEL SENSOR SWITCH is in the correct position for *No Water* in tub.

If the INLET VALVE--LOW LEVEL SENSOR--FLOW METER function normally----replace the MAIN BOARD.

Share this post


Link to post
Share on other sites

I cleaned some gunk out of the water level sensor and found a piece of plastic in the drain pump housing just like you said. Thanks for the help.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0