Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Sign in to follow this  
Followers 0
t-bag

Kenmore ultrasoft400 low water psi

3 posts in this topic

My watersoftner is 7 Years old and causing low psi in the house. I have a bypass setup and with the softener bypassed water psi is fine... What do I do????

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Has it been working (Model Number ?), regenerating/using Salt etc ? have you tested your water to see if it is working ?

Share this post


Link to post
Share on other sites

I would run resin bed cleaner through it and see if there is any improvement assuming that you have a sand and sediment filter upstream or the softener. have you changed the rotor seal kit since it was new?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0