Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Kenmore Dehumidifier 580.54701500 - lights, no action


  • Please log in to reply
3 replies to this topic

#1 dharwick33

dharwick33

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Flavorite Brew:Yuengling Lager

Posted 30 October 2011 - 08:21 PM

-

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 appl.tech.29501

appl.tech.29501

    Sensei

  • Academy Fellow
  • PipPipPipPipPip
  • 8,025 posts
  • Location: USA
  • Flavorite Brew:Waffle House Coffee

Posted 30 October 2011 - 08:58 PM

Need a little more infomation,

What light (s) ?

error code?

Full light?

No sounds at all?
If you would like to make a donation you may do so at the link below

One on one repair help now available !

http://homepage.mac....ppl.tech.29501/

http://twitter.com/ApplTech29501

http://www.facebook.com/ApplTech29501

www.eliteapplianceservice.org

#3 dharwick33

dharwick33

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Flavorite Brew:Yuengling Lager

Posted 30 October 2011 - 09:45 PM

- Plug in unit, lights on panel come on, but neither fan or compressor run.
- "Bucket full" light is off, but comes on when I remove bucket.
- I can change humidity up to 70% and down to "On".

#4 dharwick33

dharwick33

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Flavorite Brew:Yuengling Lager

Posted 30 October 2011 - 09:51 PM

- Plug in unit, lights on panel come on, but neither fan or compressor run.
- "Bucket full" light is off, but comes on when I remove bucket.
- I can change humidity up to 70% and down to "On".
- I can change the energy save cycle
- pushing fan speed button does nothing
- I removed PCB, pressed power button on board, does nothing. Press & hold sometimes shuts off unit, sometimes doesn't. Quick press or press and hold will not turn it back on, I have to unplug and replug the unit to get it to come back on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics