Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Lost with the new appliances? The Samurai teaches you Circuit Fu…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
lclontz

911.4672992

7 posts in this topic

I have a Kenmore electric range, but all of a sudden the bake functions don't come on at all. Pressing "bake" makes the clock blink and the up and down temp arrows don't do anything. The timer works, but it won't turn on at all. Any suggestions?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Do the Top Burners work ?

Does the Broil work ?

Try the Bake Function with the Oven Light ON

(or the Door open)

Share this post


Link to post
Share on other sites

Could that Model Number be 911.4672992 ?

Share this post


Link to post
Share on other sites

Yes, it actually is 911 -- the number was slightly rubbed off. Good call.

The top burners work fine. Broil acts just like bake, as does clean.

Thanks for any thoughts.

Share this post


Link to post
Share on other sites

Kenmore 911.4672992 made by GE Roper

Did the Bake and Broil stop working at the same time ?

Have you recently used Self-Clean ? :nono:

Share this post


Link to post
Share on other sites

Yes, bake and broil both started this behavior at the same time. I've never used self-clean on the oven -- I just tried pressing the button to see what it would do. Same deal: the display just blinks.

Share this post


Link to post
Share on other sites