Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

SilverSurfer

Frigidare W/D #GCET1051FS2 LOUD knocknig sound when in spin cycle

12 posts in this topic

Hello,

SO I have a vary basic understanding of appliances. Enough of one to be able to replace the transmission in the washer.

It had locked up and wouldn't agitate so I had to order a new one.

After going through all that ( I had to work in an apartment building) I put it together and it makes a loud knocking sound when it really gets into the spin cycle.

I made sure to get the screws on snug that hold the base of the trani in place. and there was not one spare screw when I was done.

I've attached a link to an audio clip of the sound

Thanks a lot!

Click to hear Washer Sound

-Dave

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

The sound link goes to a "sign up" page - you might want to check that the trunnion clamp bolts are securing the inner basket to the shaft and the clamp piece is located over the flat spot on the shaft

Share this post


Link to post
Share on other sites

The sound link goes to a "sign up" page

... works for me ...

Share this post


Link to post
Share on other sites

The sound link goes to a "sign up" page - you might want to check that the trunnion clamp bolts are securing the inner basket to the shaft and the clamp piece is located over the flat spot on the shaft

So I took the agitator off to take a look and it seems to be fully connected correctly.

I ran a spin cycle with it off to and it didn't seem to move at all.

The clanking metal banging sound only happens some times, I'd say 1 out of 3 spin cycles its gets really loud other times its pretty quiet. Still makes the sound but its quieter.

When its in spin and not making the sound very loudly if I put my hand on the outer drum and hold it, the harder I push on the drum the louder it gets.

sounds like its coming from the transmission area below.

WAsher.mp3 - 0.15MB

IMG_1501.jpg

*Try that Washer.mp3 link ^^

Share this post


Link to post
Share on other sites

Check the 3 arms that extend from the base that the tub bolts to - inspect them on the inside where they are spot welded to the middle, the welds have been known to crack. Also make sure your belt doesn't have a divot or some other damage to it.

1 person likes this

Share this post


Link to post
Share on other sites

i felt all 3 arm basses and they're all attached and strong.

The belt has no divots in it ether.

I did notice that only 2 of the 4 screws that hold the square bass of the trani in place are missing.

I'll try getting those in.

the original trani didn't have all 4 in though, and I only have one extra from the old one but I'll give it a go.

Share this post


Link to post
Share on other sites

It turns out just putting the third screw in stopped it.

.... but now,,, strangly, it has no power. I touched nothing electrical besides the washer door switch.

Do these models have one master fuse or 2 for each?

Share this post


Link to post
Share on other sites

putting the third screw in stopped it.

strangly, it has no power.

:kopkrab:

How do you know the noise stopped if it has no power ?

Share this post


Link to post
Share on other sites

it stopped in the middle of a wash. and I ran it on spin right after fixing it so that parts fixed.

but the strangest thing is it seemed like the whole unit was dead at first but, later on in the day the dryer just stared working.... first had no response to starting it, now all the sudden it works...

washer is still dead though.

:huh:

Share this post


Link to post
Share on other sites

check / inspect / tighten / the Nuts on the Dryer Power Cord

Share this post


Link to post
Share on other sites

It stopped in the middle of a wash just after filling.

and I ran a spin cycle right after fixing it.

the dryer works fine now.but no washer power now.

used to be both washer a dryer now its just washer is dead.

Share this post


Link to post
Share on other sites

GCET1051FS2

maybe

GCET1031FS2 ?

Share this post


Link to post
Share on other sites