Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

AMANA GUID090EA50

UNINTECIPATED FLAME PRESENT

  • Please log in to reply
9 replies to this topic

#1 hawgwildtours

hawgwildtours

    Yamabushi

  • Appliantologist
  • PipPip
  • 98 posts

Posted 20 December 2011 - 01:38 PM

This furnace led blinks continuously and the the burner lights but goes right back out. My friend changed the flame sensor but no help. Any ideas beside main board????thanks in advance

Edited by hawgwildtours, 20 December 2011 - 01:41 PM.


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 20 December 2011 - 02:03 PM

This furnace led blinks continuously ...

continuously, ?
OR repeats a certain number of flashes ?
.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#3 hawgwildtours

hawgwildtours

    Yamabushi

  • Appliantologist
  • PipPip
  • 98 posts

Posted 20 December 2011 - 02:06 PM

I was wondering the same thing. I will go by his house tonight and see

#4 hawgwildtours

hawgwildtours

    Yamabushi

  • Appliantologist
  • PipPip
  • 98 posts

Posted 20 December 2011 - 02:10 PM

I just called him and he says it is continuos

#5 Dan Webster

Dan Webster

    Paw Paw

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,324 posts
  • Location: USA
  • Flavorite Brew:Busch

Posted 20 December 2011 - 03:33 PM

Continuous flashing on the LED might mean your furnace has a reversed polarity of 115 volts. Turn off the power and correct the wiring polarity after reviewing the wiring diagram

Edited by applianceman18007260692, 20 December 2011 - 03:34 PM.

"May the hinges of our friendship never grow rusty"
-old Irish saying

Buy me a Beer: http://web.me.com/ze...man18007260692/

#6 Bobice

Bobice

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 277 posts
  • Flavorite Brew:coffee

Posted 20 December 2011 - 06:37 PM

AMANA & GOODMAN FAULT CODES

1. One led flash that stays on continuously = No signal from thermostat. Turn off power and check connections.

2. One led that flashes = Furnace lockout after three attempts to fire. Must be reset by lowering it for twenty seconds and then raise it back. After one hour furnace will reset itself.

3. Two led flashes = Draft Inducer not working or shorted or failed pressure switch.

4. Three led flashes = Open pressure switch.

5. Four led flashes = open primary limit switch due to faulty wiring or bad filters.

6. Five led flashes = Sensing flame without a call for heat due to possible slow closing valve.

7. Seven led flashes = faulty flame sensor

8. Eight led flashes = faulty igniter

9. Continuous led flashing = Reverse polarity. Check wiring diagram
Retired US Army Refrigeration Specialist / NYC Board of Education HVAC/R (Retired)
40 Years HVAC/R service, sales,installations. a tragedy has happen to me : http://web.me.com/zenzoidman/Bobice/

#7 hawgwildtours

hawgwildtours

    Yamabushi

  • Appliantologist
  • PipPip
  • 98 posts

Posted 21 December 2011 - 06:04 AM

My friend had changed the igniter instead of the sensor. I cleaned the sensor and all is well. As for the blinking light this furnance was wired with 2 thermostats for a two story house and they used two boards. There was a green led on the add on board but it was saying normal operation. Main board did not have power to it until downstairs called for heat. Thanks again for all help

#8 jb8103

jb8103

    Senpai

  • Chief Appliantologist
  • PipPipPipPip
  • 534 posts
  • Location: USA
  • Flavorite Brew:Ginger ale

Posted 30 December 2011 - 06:33 AM

My friend had changed the igniter instead of the sensor. I cleaned the sensor and all is well. As for the blinking light this furnance was wired with 2 thermostats for a two story house and they used two boards. There was a green led on the add on board but it was saying normal operation. Main board did not have power to it until downstairs called for heat. Thanks again for all help


Two boards for one furnace? Never seen that before.
First, do no harm.

#9 Shootist

Shootist

    Yamabushi

  • Appliantologist
  • PipPip
  • 60 posts

Posted 04 January 2012 - 08:42 PM

When getting a flame sensor error always make sure the furnace is properly grounded before you do anything else. An ungrounded furnace will pull a little ground off of the gas line but this is not a good ground source and the furnace will work when it feels like it and drive you up a wall. If the ground is good then cleaning the sensor rod with a little steel wool or fine grit sandpaper will usually fix it.
I had a customer once that had a heater problem. Every fall their previous A/C guy had to come out and replace the flame sensor. This went on for years and finally they got fed up and called me instead. I knew right away the problem once I saw the old 2-prong socket in the attic. Luckily the water heater was close by so I ran a new ground wire to a ground clamp on the cold water line and the furnace fired right up. The following fall I got a "thank you" card from this customer because it was the first time in years the furnace worked right the first cold spell.

#10 michla

michla

    Samanera

  • Grasshoppah
  • Pip
  • 8 posts

Posted 13 January 2012 - 10:58 AM

I know this might be a little late coming, but I had the same problem with your model last Spring. A closer look revealed a pressure switch (round diagpham cannister looking thing with small hose attached to it) that was tripping off prematurely. The Draft Induced Blower (first thing to start in the forced air heating cycle, purges exhaust gases to exterior) has a purpose-built hose nipple to send positive air pressure down that small hose via the spinning fan in the DIB....be it ever so small CFM of air movement.

Problem is, if anything is compromised in that small air signal to the pressure switch, the diaphram plunger pintle will not extend far enough to comletely and consistently trip (close the contacts) in the lever microswitch (mounted on one side of the pressure swith pot) to send the signal the controller (LED box) wants to see. Any interruption/failure in the pressure switch tells the Controller the Draft Induced Blower is not running (even if it is) --which is an UNSAFE condition and the entire heating cycle process comes to an abrupt halt.

So, what you've got is a weak air signal to the pressure switch, which can be caused by:
--ruptured/torn rubber hose from DIB to Pressure Switch
--tired DIB spinning at lower rpm's creating less air movement than needed
--an "air leak" somewhere in the intake/exhaust manifolds for the DIB
--a faulty and/or leaking pressure switch

I finally found a new DIB on Ebay (they're very expensive) for my Amana just like yours, but that still didn't cure the problems like you're experiencing. It wasn't until I played with bending the microswitch metal mounting tab on the pressure switch that I could affect a changed relationship of the air signal/pintle engagement at the microswitch that made the big difference. It was very tricky positioning that arc of bend in the tab just right, but after much patience and testing, I finally got it right. You have to be very careful though by bending the tab only micro-inches at a time in your trial-and-error process---too much bend and the furnance cycle gets befuddled by the sequence of the switch contact cycle.

Just don't let any appliance parts salesmen talk you into buying one of those "Adjustable Pressure Switches" if you decide to replace yours instead (it may still need tweaking anyway). The adjustables are not only junk, they never operate consistently and will confuse your furnace even more! I know...I tried one.






Recent blog entries on this topic

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics