Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Isn’t it time to know what you don’t know?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Sign in to follow this  
Followers 0
Syclone

KitchenAid built in oven KEBC107

5 posts in this topic

Back when the time changed my wife attempted to reset the clock. She somehow has locked the screen but only with respect to the clock. We can use the oven just fine. Anyway, oven controls are all blank. Push clock and the correct time will display AND the word "start?" pops up over on the oven control side. Push cancel and the clock & "start?" both go away. If we just wait it will do it on its own. No amount of button pushing that I've found will allow the clock to display normally.

Side note: I thought that maybe she somehow activated Sabbath Mode but I can't get it to turn on of off either. Presumably it's in the off mode but with the door open as instruceted it won't let me do anything. Any button push just gets me 3 beeps is close succession.

As it happened we had a power failure a couple weeks ago for about 2 hours. Hoped that would help but no luck. Problem still exists.

Thanks.

Don

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

KEBC107

missing (4) characters at the end of model number

Do you have the tech sheets for Sabbath ON/OFF ?

Have you recently used Self-Clean ? :nono:

Share this post


Link to post
Share on other sites

Thanks for the reply,

Last digits are: KSS03

Sabbath mode works as far as I can tell. I can get it to say Sabb on and then off.

So the problem, stated differently is:

1) Walk up to oven ALL displays are off

2) Press clock and it shows the time and within a couple of seconds the word "start?" appears on the oven display. Push clock start and everything, including the clock, goes blank.

Share this post


Link to post
Share on other sites

Not sure if you tried this as it's not mentioned in your post but have you cut power to the oven for at least 10 minutes to see if it will reset itself?

Share this post


Link to post
Share on other sites

Push and hold the clock button for about 10 seconds and see what happens.

I've can't recall every hearing of Whirlpool doing this but I do know some of the Frigidaire's have the option of the clock not displaying except when you push the clock key, then it will go out after 5 to 10 seconds. The option to put it into and out of this

mode is to press and hold the clock key until it beeps or something, (about 5 to 10 seconds), toggles option on/off.

Can't hurt anything to try it.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0