Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to troubleshoot using schematics like a real tech…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.

Intermittent filling problem with Maytag MDB9100 AWB JETCLEAN DISHWASHER EQ - Plus!

51 posts in this topic

Intermittent non-filling. Sometimes it fills and sometimes it doesn't.

Maytag Model: MDB9100 AWB, SN: 15616100YM


Purchased January 2001

One day I noticed that after the first wash cycle (which DID fill), the dishwasher sounded like it was trying to wash without any water. Sure enough, I put 2 gallons in manually and everything went fine. On another occasion, I added the water manually at what seemed to be the right time- good thing, too, because I ~think~the heating element was trying to heat water that wasn't there! I ran it once again (babysitting each cycle) and everything was fine. I ran it once more again and the although the first fill went well, the second? did

not happen. I had to add the 2 gallons myself. So, I have an intermittent "no fill" situation.

I ran the Automatic Function Test. No errors.

I have not tried the "no power to dishwasher for 24 hours" that has been mentioned online...though I don't see what that would do. Is there a "reset" button somewhere? Is the no power for 24 the procedure to reset it?

In December of 2007, under the fire risk recall, we replaced the PCB Controller (99002825) which the tech noted was "found to be smoked" and some kind of $14 "kit" (re-wire? re-work? I forget what this was; perhaps for a different project even) (part 330031).

Back in December of 2008, we again replaced the control board (99002825); it was fried by a power surge.

I wonder where the float switch is located in my unit? Inside: close left corner? The thingy that kinda spins, can be moved up and down and might actually float? (The thingy on the right close corner doesn't move). I wonder how to test the float switch?

Probably unrelated: I read somewhere that dishwashers actually LIKE dirty dishes, though I tend to pre-rinse my dishes almost all the way to clean. I currently use Method Smart Tabs for the soap, and vinegar instead of a commercial rinse aid; Pacific Northwest municipal water (that's actually pretty good; I purify it for drinking/cooking).

That's all I can think of.

I am all ears and hoping for your expert guidance and help.

Jizen ni arigatōgozaimasu (TIA)


Share this post

Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Thanks Poop - will see if I can (1) find the valve, and (2) reach it, and (3) figure out which of my flaky multi-meters work and how to use it (really)

Couldn't it also be a stuck fill switch - something about the floatie thingie?

Thank you for your reply, too


Share this post

Link to post
Share on other sites

See the video in the part link for general valve replacement, your float would be stuck on all fills, not just the first

Share this post

Link to post
Share on other sites

Water inlet valve replacement video:

thanx poop

You just like saying, "poop." :sillytongue:

Share this post

Link to post
Share on other sites

LOL! Honto! (<--true) Or, you just like hearing it!

What an awesome video! Thank you! (Especially if I must go after the valve)

Here's my story, and I'm sticking to it.

Instead of noticing kdog's advice, I obsessed onto the switch instead of the valve. As most here probably already know, it's the black box with two blue wires going to it in these two shots looking into the area under my washer. I mention (and photographed) it because it acted in a way I did not expect. I wonder if anyone can shed some light on this:


When the water fills, the float floats and rises. The float's stem (when not floating) rests on a white spring-loaded lever-arm that presses a switch or button. I assume this to be like a dead man's switch in that during filling time, the arm holds the switch and the valve is allowed to let water in. Once the float rises, the rocker arm releases the pressure on the button and the valve is no longer allowed to let water in.

That's what I ~think~ is supposed to happen. I had surprise company while I was watching the process so, I may be mistaken. What I believe happened is that the water filling shut-off even without the stem rising to release pressure on the kill switch button. I could swear I saw it rising, then going down again once the washing started. Something like that. I'm probably confused. On the second fill, it didn't rise at all, and the water still shut off. That's what I think happened, but will really have to verify this with another load of dishes.

Still obsessing on the switch, I pulled the two blue wires out just enough to allow access of my two multimeter prongs. It's a battery powered, antique Radio Shack Auro-Range (POS?) Digital Multimeter. I am not sure the thing even works, though a nearby AC socket shows 121.4 V. I put the meter on AC V and without touching the probes to anything it's reading 4.7 to 5.7 mV. What's up with that? Uh oh. Memory from today kicks in. Partial grasshopper error. I think I tested my switch pins today with the meter set on DC V. Probably lucky the meter didn't blow up. Had wacko readings varying widely from 45 to 149 to 170 and down again. I wonder what that was. Never mind. I'll be more focused tomorrow.

So, my next mission is to have a nice meal and create some dirty dishes. This will take a day or two. Then I'll test power to the valve pictured below with a black and a blue wire connecting to the orange part of the valve.


It'll be fun to see if the float and its switch behave like I assume they are supposed to, and to test the VALVE's power in AC mode. Maybe the float switch only has to send the kill signal once, then the agitation/spray pushes the float back down again. I dunno.

I just went and stuck my camera back in there and located each area that I'd need to access in the case of a valve replacement. I am able to reach everything so it's a doable thing.

Aren't you glad you stopped-by? Hope you got some entertainment (and feel free to teach me anything you care to share).

kiotskatei...and Best,


Share this post

Link to post
Share on other sites

Set the meter on AC Voltage - 200 v scale, insert the probes into the back of the wires to the water valve (do not unplug wires). Start cycle and watch meter - whenever the valve is getting 120 VAC (or thereabout within 10 percent), it should be filling with water. The float switch only comes into play should something malfunction and it gets overfilled, normally it isn't involved in the process.

Share this post

Link to post
Share on other sites

thanks poop daddy - tomorrow (or the next day) :)

Share this post

Link to post
Share on other sites

OK, it's the next day now. Running a load. Keeping a diary; here it is

I have selected "extra rinse" and understand that the setting adds an additional rinse at the end of all the wash/rise cycles.

FIRST FILL 112V AC while filling.

The float switch only comes into play should something malfunction and it gets overfilled, normally it isn't involved in the process.

The float DID rise, released the pressure on the lever, and therefore the pressure on the float switch button. Filling stopped, although I am not certain it was because the float rose enough or some other sensor/timer was activated. Are you saying this float rising and releasing the button on the switch is a malfunction?

I notice that at first, the first fill water is tepid...NOT hot...(and not ice cold either). There is plenty of hot water at the kitchen sink; I'll go check that. I just measured it at 117 degrees F. Partner did use the shower today and our water heater usually puts out at about 135 degrees. Now a few minutes into the first wash cycle, the water inside the washer seems to be heating up a little and reads 101 degrees. It IS warmer than it was. Is that normal? ("heating delay" indicator light not lit)

PAUSE - From the other room (typing this) I hear the drain cycle starting so I raced into position, but, before I could get down on the floor it resumed washing. OK, whatever.

During this cycle, the meter reads 60-130-200 mV AC

DRAIN - I race for position before the drain cycle ended.

2ND FILL 111-112V AC while filling. After filling there was a long? pause...pause estimated at about 2 minutes. During this pause, meter reads 97 V AC. When this second wash/rinse cycle started spraying water, the meter still reads 97V AC. Meter reading dropped to 38 V.

Thinking about the float NOT rising this time, I became curious about the water level. It sounds pretty much like a wash/rinse cycle...maybe a little weak. I opened the door and nothing on the top rack was dripping. I removed the rack and took a photo. I placed a chopstick floating on the water. Both ends of the chopstick point to the water level. I suspect this is inadequate filling.


So, I decided to add some water myself. Added about a gallon! Here's the level I added it to:


I see that the float has water on it, though not enough to lift it.

With this amount of water, everything is dripping when I open the door.

Next, it went to the DRAIN cycle, meter at 36 V AC. Then the drain stopped and there was silence and a reading of 98 V AC (isn't a small amount of water supposed to be added to keep some sensor submerged?)....then "Dry" indicator lit up and voltage went down to 13.5 V AC.

So, is it the valve? I hope these are enough clues. Naturally I wish to understand and repair this.

Oh! One more clue! (and issue)

Spotting: We have been using vinegar as a rinse-aid for ages with great results. Dishes from yesterday were terribly spotted. This problem has been a recent development. Either the graphics on the rise aid dispenser cover and adjustment are confusing, or I am just confused. Here is a shot of how it's set now. (I think this is where it's been)


Is this correct for maximum release of spotting aid, or should I move it over to open by turning it counter-clockwise to "open"? Like this:


It's counter-intuitive to me that MORE rinse aid would be released with the cover turned clockwise all the way (like the first of these two photos) and of course, if I keep turning the over counter-clockwise it does come off.

Thanks in advance!


Share this post

Link to post
Share on other sites

You could have a valve issue, but 97-98 volts is concerning - the electronic control could be failing, or wiring/connections between. I think these units had a tendency to leak rinse aid (in your case vinegar) on the inside of the door that could end up damaging wiring. Try testing the valve by starting a cycle, letting it fill and begin washing for a few minutes, then cancel/drain the cycle. repeat this several times (watch voltage) - see if the valve continues to fill each time you do this.

The setting you have the dispenser is for maximum dosing.

Share this post

Link to post
Share on other sites

Thanks for all the feedback - Here's today's report and questions.


(fill, examine water level, allow to wash for a couple of minutes, drain, turn off, repeat - while watching valve voltage at each stage all Vs are AC)

1st fill - 113-115V - filed well - proceeded to wash cycle and current dropped to 35V AC (pattern: first fill seems to usually succeed)

2nd fill - 111.2-112.5V - dropped to about 95V and filling ceased (pattern: with 95V filling always ceases) - seems to be a good fill - (<--poor notes)

[curious that there is always 35V at the valve when off, draining, and on delay, I tripped the circuit breaker to make sure there really was current. Breaker tripped: zero current. Breaker on, 35V unless filling with 112V or going into weird limbo at about 95V]

3rd fill - hit Auto Clean as usual - watched meter - after 5 seconds: 95 V and silence (should be filling but isn't) - 2 minutes later machine went into 35V wash cycle with NO water! - turned it off.

4th fill - 95V and no filling....for fun I manually lifted the float stem to release pressure on the float switch button and current dropped to 12V

5th attempt tried "Rinse Only" with same results 95V and no filling


1st fill - all good (temporarily) with 112V - float rose up to release pressure on float switch button*

2nd fill - filling with 112V - then meter reads 109-110V (poor notes on what happened) - dropped to 16V and silence for 25 seconds - went to wash cycle with 35V


1st fill - 112V good fill - float rose and lever released pressure on switch button - filling stopped 107.9V - 15 seconds silence - wash started (and the spray depresses the float, rocking the lever and again depressing the switch button) - 2 minutes wash cycle, then I drained it - during drain cycle, current at valve was 123mV (<--milli Volts)

2nd fill - you guessed it - current while still "off" is 35V - pressed "Auto Clean" - filled for a while at 110V - dropped to 95V for 45 seconds of silence - water level NOT achieved - bad I drained it and called it a day.


I opened her up and looked for anything obvious like a smoked board...bad connections, etc. I removed a loose plastic sheet protecting the control board and cleaned it. Put it back in place and used a knife to press the glue/sticky edge back onto the plastic. Removed the cover over the rinse-aid dispenser and looked at stuff. Nothing wet, nothing anything....looked fine. Checked at the base of the door for any signs of leakage - none. Put everything back together and wiggled any connections I could reach under the unit. (If vinegar or rinse aid ran down the wires, they wold not make it to the connections because they are in a "U" position and the liquid wold fall off before reaching any connection.)

Then, I learned how to do a continuity test with the cool video here. TYVM. I removed the filling switch and did the test on it. Touching the meter's probes together while set to "cont" caused a tone I could hear. With a probe for each contact on the switch: no tone. I depressed the switch button and got the tone. I am not sure if that's what's expected since this seems to be some kind of shut-off switch. Should I say "there is continuity as long as the button is pressed?

(1) Can a flaky float switch cause this weirdness? ($11 would be nice)

(2) Is the continuity test I did the final say on whether or not the switch has weirdness?

(3) *Someone (kdog) said that the float switch only kicks-in with a malfunction. Is this so? If so, how does the machine know it's got enough water? Is there a float (and switch) somewhere else? I'd love to understand this...process as well as understand this switch.

(4) If the verdict is control board (3rd one for this machine; 31: recall, #2 power surge...) is there a video here with tips on removing and replacing? Most of it's probably obvious, though there are some connectors on the board that have latches or clips that need to be released and maybe some that just get yanked. I'd hate to be yanking on one that really needs a clip nudged for a

OF COURSE I look forward to the next batch of feedback, directions, and answers...



Share this post

Link to post
Share on other sites

... (1) Can a flaky float switch cause this weirdness? ($11 would be nice)

... (2) Is the continuity test I did the final say on whether or not the switch has weirdness?

1) yes, otherwise I wouldn't have posted that link

2) NO ... shouldn't use "tone" test...

set OHM meter for 200 OHMs and short the probes together.. should read nearly 0.00 OHMs

now test the Switch with that setting

Share this post

Link to post
Share on other sites

USReg - thank you. I do tend to sometimes re-ask an already answered question; I had not noticed you are Staff and probably know what you're talking about. Pardon me.

I am not sure if I am able to perform the test with the "meter" I have. I believe it's an antique and multimeters are really new to me. (I'm pretty good with a battery tester). I don't see any setting for 200 OHMs. Here's what I have....the relevant page in the manual and the unit set on "cont" and shorted, reading 6.2 OHMs:


I don't know why the readings fluctuate so widely. Maybe it's super sensitive or something...Here's a shot with me holding the leads together after I waited for it to settle down.


And here is a shot of the reading of the switch with the switch button depressed by pressing it onto the table (and after settling down)


When I was testing the switch, the readings were all over the place: 8.6, 12.2, 14.6, 17.1, 8.7...I am clueless.

If you can make sense of this, that'd be great. Otherwise, I'll probably be on the lookout for a real multimeter and will probably get one of these switches for $11 and test the new one in the dishwasher...

Thank you (and everyone) for your kind guidance.

and TIA


Share this post

Link to post
Share on other sites

Your meter is an AUTO-RANGE meter, set it to the K ohms setting and see what you get.

You will probably get the same readings but without the beeping. The continuity check setting that has the beep only reads up to a certain lower ohms reading, it should be OK for checking switches or anything that would have a ohms lower than 50 or 60 ohms, (depending on the meter specs it may even be lower than 50 or 60 that the continuity check will work on).

Share this post

Link to post
Share on other sites

... When I was testing the switch, the readings were all over the place: 8.6, 12.2, 14.6, 17.1, 8.7...I am clueless.

either the Switch is bad, and / or you need a better meter

Share this post

Link to post
Share on other sites

Thank you Sensei *bows*

I think this meter is screwy. All my other electronic gear, (cameras, computers, phones, battery meters) seem to give 'all or none,' definitive, exact responses. Like, either something is on, or not on. I'll admit that weak batteries have affected performance of various things.....anyway....the readings I am getting change about 4-6 times per second and are so "all over the map" I consider them unreliable. I have spent way too much time being OCD and trying to make it work. It just doesn't.

I'll get a new switch soon as I can. Good thing I actually enjoy cooking and washing dishes.

Thank you (everyone) for sharing your wisdom.


Watashi wa yoi nyūsu de o ai dekiru koto o negatte imasu.

(I hope to see you soon with good news.)

~drcarl san

Share this post

Link to post
Share on other sites

Couldn't you jumper the switch and test to verify ? The fact that you always seem to get a good fill the first time out raises some suspicion

Share this post

Link to post
Share on other sites

kdog - how does one jumper the switch? get a big ol' piece of copper wire and essentially connect the two leads? (then flip the circuit breaker to turn the power back on?) --and run a load? [thinking: bypassing the switch would tell is if it is the switch]

It occurs to me that nobody has answered my question about how does the machine know to cut off the filling water if it's not this switch? Is there another sensor? Is it a timer? So many rotations of a wheel?

Also, get a good fill first time out raises some suspicion of what? Or, this leans us toward thinking what? Please elaborate?

Sidebar, I was going to post a new issue about sounds I was hearing during the draining phase...sounds like a screw, or a rock, or a piece of glass is being spun-around. First, I looked for "maintenance" videos and found one for the Maytag. It's a wonderful thing to go from "how the heck do I get the spray-arm off!" to "reassembly complete!" after having taken apart and cleaning everything down to and including the plate the cutting arm spins above.

The remaining water was a goldmine of plastic bits, some paper from a label, and, you guessed it...a few pieces of screw-sized glass! I cleaned everything put it all back together...kind of like paint by numbers. <-- The video was completely awesome. After cleaning one part, I found some round plastic thingies in the sink and am pretty sure they would have wound-up in the right position. I was 100% sure they were correctly placed when the video said "make sure the bearings are in place" and showed me my round plastic thingies. LOL and thank you very much!

moichido (one more time) TIA


Share this post

Link to post
Share on other sites

The fill cycle is based on time (approx 2 min) - the valve has an orifice which is sized to pass a certain volume in that time - although you may notice the lever lift at the beginning of the fill, the switches function is to prevent it from overfilling. Connect the switch wires together and try filling the unit multiple times to see if the voltage supplied to the valve improves.

Share this post

Link to post
Share on other sites

Thanks! I checked my silverware basket and think it looks pretty much intact. I recognize 4 of the bits...rubberized "ends" for some wire rack. They look similar to a repair kit for old dishwasher racks....these were for something'll come to me. The glass is about as big as a .22 short. There was more glass, and more plastic, too. Here's a shot of the bounty in a plastic bag next to a quarter and a ruler for scale (toldja I was OCD - lol)


And now, I have good news and bad news. Which first? OK, the good news...I made a jumper from a wall hook I found rummaging in the garage. After a couple of bends with pliers, it looked exactly like the tabs coming off the switch! I tested it for conductivity in an AC socket. Perfect.

Onto the test: Fill switch removed (I'm getting fast at that) and leads jumpered. Watching timer, voltage, float stem, etc.


0:05 filling - 112/113 V AC

1:38 float pin rising

1:53 washing (and sounds like still filling, too)

2:00 just washing

3:00 hit delay (and pause on the stopwatch) check for fill (redundant because I already saw the pin rise)- good fill

4:00 drained


0:05 filling - 112v

0:54 silence - 95V (or 94V) no filling - float pin motionless (duh)

1:56 washing cycle starts - valve voltage is now at 31VAC

2:27 with a sad heart, opened dishwaasher to find incomplete fill

2:27 drained

THIRD FILL (I'm having so much fun, may as well do it again)

0:05 no fill - 6V? - then 95V - no float pin motion - no filling sounds

(maybe my meter's whacked; try again)


0:05 95VAC :(

So, that's the good news. Looks like the switch is not at the root of this. Please confirm. I don't have to spend the $12. yay.

It also looks like I get to spend $240 on a new master control board. Please confirm this, too.

Couple of questions (as usual)

The first board replacement was in '07; this was the recall and actually was a "smoked board." (lucky no fire) The second replacement was due to a power surge (according to my notes). Now here comes the third (upon your respected opinion/validation). I know it's an impossible question....humor me, please

(1) Why did my board go bad?

(2) Are boards ever repaired? My partner asks, "can it be fixed?"

(3) Lastly, (<--yeah right) can I install it? I had it halfway off already...took the smaller yellow? board off of the longer, thinner green board to look-around...stopped there...I am unsure about some of the connectors. Is recognizing how to pull connectors off easy enough?

Sincerely, thank you.



PS - kdog, thanks for the info on filling....btw, the lever (actually float pin and lever) lifts at the end of the filling probably meant that...TYVM.....;)

Share this post

Link to post
Share on other sites

Yup - sounds like a controller issue, check with Bruce over at and see if they can repair the board

Share this post

Link to post
Share on other sites