Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Sign in to follow this  
Followers 0
RyGuy

Maytag MAH6700AWW washer - no high speed spin

4 posts in this topic

I have a MAH6700AWW that the board went out on. I got a new board and put it in and now it seems I have other issues.

The unit will not reach high speed, clothes come out wet. The pump works fine, as I also put in a new pump and checked for clogs.

I ran all checks and they all come out OK. The error code I get is 8e or e8. My model is version 11. The board they sent me is the newer one that has ports for the mems unit. They did NOT send me a mems unit with this board. Could this be whats causing my issues?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

What was the reason you replaced the board, because of the spin issue ? there is literature that states series 10-14 did not have the mems pcb, but notes that if the mems harness has the harness reversed between the control and the mems, that the machine will spin at 180 rpm maximum.

The R/C link shows the harness included with the control:

 

http://www.repairclinic.com/PartDetail/Main-Control-Board/34001479/1185457?modelNumber=MAH6700AWW

 


Main-Control-Board-34001479-01025726.jpg

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0