Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

GE JKP13GOV1BB oven display is blank the inside oven light will turn on

Blank display

  • Please log in to reply
4 replies to this topic

#1 Joenew

Joenew

    Unsui

  • Grasshoppah
  • Pip
  • 2 posts
  • Location: USA

Posted 12 March 2012 - 12:36 PM

The oven display is blank however the inside light will turn on. how do i trouble shoot this

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Chat_in_FL

Chat_in_FL

    Sensei

  • Academy Fellow
  • PipPipPipPipPip
  • 1,145 posts
  • Location: USA
  • Flavorite Brew:on the house...

Posted 12 March 2012 - 02:09 PM

Looks like control and light receive power from L1, so you probably have a bad control.

Attached Files


We, the unwilling, led by the unknowing, are doing the impossible for the ungrateful. We have done so much, for so long, with so little, we are now qualified to do anything with nothing.

Mother Teresa

#3 Derik

Derik

    Sōhei

  • Chief Master Appliantologist
  • PipPipPip
  • 235 posts
  • Location: USA
  • Flavorite Brew:coors light

Posted 12 March 2012 - 06:16 PM

Have u tried to unplug it for couple minutes and luging it back in???

#4 Joenew

Joenew

    Unsui

  • Grasshoppah
  • Pip
  • 2 posts
  • Location: USA

Posted 12 March 2012 - 07:44 PM

I have unplugged no response. I have 120 across L1- N, but only 80 across C-N which I think should be 120v. Does this help?
Thanks for your responses!!

#5 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 12 March 2012 - 09:41 PM

Looks like control and light receive power from L1, so you probably have a bad control.


The oven display is blank however the inside light will turn on. how do i trouble shoot this


.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw





Also tagged with one or more of these keywords: Blank display

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics