Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

M@rt1n

electric range

6 posts in this topic

Hi, Guys,

Breaker is off after oven locked last night 'warming' food. I had set the oven to 170 degrees.When the oven cooled, it unlocked but now when I open the breaker it goes into cleaning mode and immediately locks without touching the oven. code PF (there was no power failure, that I did not induce). This is an all in one unit, so I can't use the cook top either.

In 2008, the oven would not go on at all. I had a repair for about $500.00 to replace the plastice cover for the touch screen. When the man went to put it on, a moth dropped from the assembly leading me to think that was the problem. Could this be similar problem?

Thanks for you help.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Kdog,

Big mis...RS6969PXGR10

Share this post


Link to post
Share on other sites

have you recently actually used the Self-Clean cycle ? :nono:

You could try setting it for Self-Clean,

but then immediately cancel it.

Share this post


Link to post
Share on other sites

RegUS_PatOff

When the power was engaged, the oven locked. I followed you advise. The oven unlocked and all appeared normal. Within 3 -5 minutes, the broiler element came on without prompting. I tried the 'set, cancel' procedure with the broiler but no go....

To answer you question about cleaning, I clean it once a year ~~ after the holidays. So the last time was in late January/early Feb. Will be the last time the auto clean is used.

Please don't give up on me, y'all. I'll try whatever is legal and moral to do this myself . . .ok, maybe not legal.

Thanks !

Share this post


Link to post
Share on other sites

..RS6969PXGR10

maybe

RS696PXGB10 ?

soo... the Oven stays unlocked and OK ?

only now the Broil has a problem ?

It may be that the Broil Element is partially shorted to chassis (ground)

Share this post


Link to post
Share on other sites