Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
robrdavis

WR30X10012 Ice maker not working

3 posts in this topic

I have a HotPoint HSS25IFMDCC SxS with a WR30X10012 ice maker that has stopped producing ice. I've traced out the wiring in the ice maker as per the diagram printed on the cover, as well as checked that the water valve is working. It seems as though it's not calling for water, but I'm at a loss as to what to check next.

Freezer is at 9 degrees so it's cold enough.

I have the tech manual for the unit, but other than showing how to access and replace the ice maker, it has no other info on the ice maker.

Is there a manual available for the ice maker itself? Any other suggestions?

Thanks!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

That's the news that I was trying to avoid. Now to break it to my customer.

The question that I'm going to get is "But it worked when we took the fridge out. Why isn't it working now?" Of course, they took the fridge out when it quit cooling for the second time. They'd had a tech come out to service it, he replaced the main control board, it worked fine for a little while, then quit again. They called a different tech out who said that he needed to replace the main control board again. They weren't happy with that answer, so they bought a different fridge and put the HotPoint on the side of the house. I got a hold of it, found the problem to be the evap thermistor and replaced both it and the thermostat. It ran fine for about 2 weeks, then the evap fan went out. I just replaced it (and the new thermistor that I just put into it) and now it doesn't make ice.

I think I have found my arch nemesis in this fridge...

Thanks for the confirmation!

Share this post


Link to post
Share on other sites