Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Kenmore Elite Front Load washer


  • Please log in to reply
4 replies to this topic

#1 Skiter29

Skiter29

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 333 posts

Posted 27 June 2012 - 06:54 PM

Im working on a Kenmore Elite front load washer Model #11049962603 ok went and serviced this unit and it was getting error codes f70 and f71 read the tech shits and it said if drum is turning replace the interface kit if its not replace the ccu the drum would turn so i replaced the interface and as i thought that wasnt it so then i replaced the CCu and of course that wasnt it either all it will do is beep 3 times when u push the power button occasionaly it will light up but if you push that start button nothing starts fortunaly i had a whirlpool duet the next day doing the exact same thing but no error codes was told to replace MCU and that one works do u think this is the same solution for this kenmore Elite Thank u for any input i shall recieve

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 mark mac

mark mac

    Sōhei

  • Sublime Master of Appliantology
  • PipPipPip
  • 235 posts

Posted 28 June 2012 - 04:51 PM

unplug the mi3 cvonnector fromm ccu if it starts and locks than its the mcu u need

#3 Skiter29

Skiter29

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 333 posts

Posted 28 June 2012 - 06:36 PM

ya ordered the mcu will be installing it tomorrow will let u know its beyound me why they have error codes and tell u to replace things and the company is way off then your stuck with expensive parts you wont use for months or years

#4 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Master Samurai Tech
  • 29,054 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 29 June 2012 - 07:00 AM

Part link to the MCU for future readers of this topic ==> http://www.repaircli...8183196/1257029

#5 Skiter29

Skiter29

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 333 posts

Posted 29 June 2012 - 03:21 PM

replaced the MCU Works fine thanks whirlpool for the run around on 2 machines




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics