Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Colint

Asko w660 blank display panel

5 posts in this topic

Hi

I have an Asko W660 with a display panel that suddenly went completely blank when putting in a load of washing. The red power light is still working, and the fuse looks fine, but the machine's completely dead otherwise. I had a look at the main control board, and that looks fine, no obvious damage. Same with the mains filter.

I have the wiring schematic, so tested the voltages on the board, and discovered that the voltage to the display panel is about 6V instead of 13V. I don't want to buy a new control board, as I don't think the machine's worth spending that much on, so I'm keen to investigate whether I can replace the transformer on the board? Problem is how to search for the part -- is it likely to be fairly generic, or will it be very hard to locate? I can send some photos if that helps...

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

If you're getting a good line voltage (120 VAC nominal) to the board and it's not outputting specified voltage, then the board is bad, slam dunk ==> http://www.repaircli...8076271/1154630

Main-Control-Board-8076271-00719098.jpg

Share this post


Link to post
Share on other sites

Yes. Are you getting good voltage to the dispplay board?

Share this post


Link to post
Share on other sites

No. The voltage on the main board where it feeds the display is about 5V where is supposed to be 13V, so I assume the main board is faulty rather than the display board.

Colin

... and I'm getting good mains voltage to the main control board.

Share this post


Link to post
Share on other sites