Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

GE Refrigerator Model #PSC23SGRC-SS


  • Please log in to reply
3 replies to this topic

#1 bogreen

bogreen

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 488 posts
  • Location: USA

Posted 07 November 2012 - 10:13 PM

Hi,

I'm going to look at this refrigerator on Friday.

Thought I'd solicit ideas from you wonderful techs before I get there, so I can
maybe arrive with the part needed to get the job done in one trip, which isn't happening much
these days.

The customer says the dispensers stopped working last week and now the whole display
has gone dead.

I know it's probably the dispenser board, but it also has one of the common motherboards
on the back and I know alot goes through there as well.

Ideas?

Thanks,
Bruce

Edited by bogreen, 07 November 2012 - 10:13 PM.


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Tuco

Tuco

    Sōhei

  • Chief Appliantologist
  • PipPipPip
  • 243 posts
  • Flavorite Brew:Tap Water

Posted 08 November 2012 - 03:56 AM

Bring a dispencer board. Unplug the old board, check for power at the plug. If the plug has a any volts, install new board.

If no power at the plug...a dispencer board is not your problem.

#3 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Master Samurai Tech
  • 29,807 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 08 November 2012 - 08:13 AM

Check the wire harness connector plug at the bottom hinge of the freezer door. If it's corroded and boogared up, you'll probably need to re-spice it.

Dispenser board part link, if needed ==> http://www.repaircli...ber=PSC23SGRCSS

Posted Image

#4 bogreen

bogreen

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 488 posts
  • Location: USA

Posted 09 November 2012 - 08:42 PM

Thank you Fermented Grand Master,

Indeed, it was the connector under the hinge. One of the wires was broken.

Thanks again,
Bruce




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics