Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Viking D/W # VDB 450 SS


  • Please log in to reply
1 reply to this topic

#1 certified tech group 51

certified tech group 51

    Sensei

  • Academy Fellow
  • PipPipPipPipPip
  • 2,394 posts
  • Location: USA

Posted 20 November 2012 - 10:43 AM

Customers complaint "Will not start" The display is flashing/blinking for ( 3 left buttons ) Pots/Pans--Normal wash---Econo wash.......Push and hold cancel button for four seconds and the 3 lights stop flashing and last cycle selected button/light will flash...................Push the start button, close the door but with-in 4 seconds the three left buttons/ lights start to flash.....You can hear relays click from the control board , located lower left, shoved under the unit ............The use and care guide states to 'Push the start button and close the door with-in four seconds'............I accessed the door switch and the door switch was depressed ( on position ??)............... No wire diagram/schematic found on the machine.....................The lady stated that it has been doing this for a while, possibly for the past year, getting more frequent...She just pressed 'cancel' and then 'start' and it would work...........I was leaning towards the door switch.............Combing the fix-it sites I found the exact complaint and the FixYa site, the guy stated a 'drain problem'........I hate to have to pull a unit and chase wires, but............................Another statement listed this Viking as an Asco model # DBF450, but I ain't seen one of them either..................................P.S. found the fault code for the three flashing buttons, it states " Flood Sensor Disconnect " is at fault............Rats, I did not see any water in the bottom, much less a " Flood Sensor Disconnect"..... Now I gotta find a loose connection... .

Edited by certified tech group 51, 20 November 2012 - 11:58 AM.


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 certified tech group 51

certified tech group 51

    Sensei

  • Academy Fellow
  • PipPipPipPipPip
  • 2,394 posts
  • Location: USA

Posted 08 December 2012 - 12:19 PM

Unit fixed............Gotta service manual from Viking .........Replaced the Moisture Sensor and the wire harness........Story in the Dojo, complete with pictures ......................






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics