Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Tired of guessing on service calls?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Budget Appliance Repair

Whirlpool Mod# WRT579SMYW00 - defrost issue

10 posts in this topic

Whirlpool top freezer with all electronic controls and thermistor in refrig for refrig temp and a thermistor in the freezer in place of the defrost bi-metal.

 

Mod# WRT579SMYW00

Ser# VS12869002

 

This is the first of these newer style all electronic controls that I've worked on so had no idea of how to put into defrost to try and test the defrost system.  Looked for the tech sheet in the control box area and under front behind kickplate and couldn't find it so went about defrosting and trying to figure out the problem.

 

After defrosting, I find no defrost bi-metal but instead a thermistor which read 970 ohms the first time I checked it just after I had removed all the ice from around it and it basically fell off the suction line.  I reattached it to the suction line, (it was really loose), and took another reading and the resistance was going up - read around 1700 ohms.   After I took it out again and squeezed the mounting clip tighter so that it would hold onto the suction line better, it was reading around 2600 ohms which is where it seemed to hold at, (this is all while warm - forgot to check the thermistor again after defrosting and starting it back up).

 

I have no idea what the specs on the freezer defrost thermistor should be.

 

When I finally found the tech sheet, (they are hiding them in the compressor compartment clipped to the back rail behind compressor cover), and found how to put into diagnostic mode all outputs worked except of course defrost - don't know if the diagnostic mode defrost check requires the thermistor to be cold or not, (heater didn't come on/ zero amps during defrost test/ heater ohms out OK at 36.5 ohms).

 

The tech sheet says that if there are failure codes to be displayed they will show by blinking the LED1-4 lights after step 7.  If multiple failures are detected the major fail is shown. It doesn't show any error code were all four LED's would be flashing at the same time, which is what I get.

 

Hopefully someone can get me a service manual for these, (I requested one in the manual request section), or at least the specs on the thermistors.

 

Some input from others that have worked on this newer style unit would also be greatly appreciated.

 

Attached is this tech sheet: W10414768, (page 2 only, page 1 is over 200kb and page 3 is just the wiring diagram)

Tech Sheet - W10414768 pg2.pdf

Edited by Budget Appliance Repair

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Thanks RegUS, but I have all that info already.   I'm really looking for the service manual that will explain the diagnostic service program in more detail and in specific the specs for the thermistors which is very important info to know but not included on the tech sheet where it is needed.

Share this post


Link to post
Share on other sites

OK, one week latter and it has frozen up again, I knew it would since I didn't fix anything and knew it was a defrost problem.

 

Haven't been able to get any help here and did extensive internet searching and couldn't find anything on this unit.

 

Knowing it was a defrost problem and the thing has a thermistor in refrig and freezer I did a resistance check on both thermistors when I arrived this time to get a base point to work with since I have no idea what the specs should be.

 

Refrig section @ 55 and thermistor read around 3500 ohms and went down to 3330 ohms and going lower as the door was open and I was checking.

Freezer @ 15, (most likely a little colder at thermistor behind evaporator panel), and thermistor read 503 ohms.

 

Jumped the defrost heater to assist in defrosting this time and when all finished defrosting took another reading of thermistors, didn't take temp readings, (everything was pretty much room temp at that point).

 

Refrig thermistor now read 437 ohms

Freezer thermistor now read 455 ohms

 

It appears the ohms should raise as the temp goes lower/colder, refrig reading of 3330-3500 ohms at 55 degrees tells me with the freezer thermistor reading 503 ohms the board would definitely think it was already warmed up in freezer and no need to defrost, (I still have no idea if it should go into defrost in the diagnostic mode if the freezer section is already warm or if like in a standard bi-metal controlled defrost termination no defrost even in diagnostics if warm or thermistor is bad).

 

So, I'm going to replace the freezer thermistor and hope for the best.  The main worry I have is the error code that flashes after coming out of step 7 of the diagnostics, (all four LED's 1-4 blink at the same time and there isn't any mention of an error like this or how a combination of errors would read out).

 

With this new info does anyone else have any more input, think I'm on the right track, recognize the temp and ohm readings to match a known chart of temps/ohms for some other thermistor?

 

Some more info that might be of use to find help is the user interface is referenced as "Opal UI" and the control board is referenced as "Hercules3" on the tech sheet.

 

Any help would be greatly appreciated, thanks!!!!

Edited by Budget Appliance Repair

Share this post


Link to post
Share on other sites

Here's the part# and a picture of the freezer thermistor if that might help some one recognize it and find a temp/ohm chart.

 

Part number: AP5305451

Part number: AP5305451

 

WHI%20W10383615.jpg

Edited by Samurai Appliance Repair Man

Share this post


Link to post
Share on other sites

Hi, Im having the same problem, What happened in the end?

Share this post


Link to post
Share on other sites

Multiple problems, the defrost problem was caused by a bad ADC (Adaptive Defrost Control board).  The relay was pushed over a little and one of the connection pins was actually pulled loose from the relay.

 

After that was fixed it still had problems, kept freezing food in refrig section, found that someone was in it before me and broke the mounting tab that holds the refrig thermistor in place so that when the lower refrig air diffuser tower was reinstalled the thermistor would get pushed out of place and no longer be in the air flow, (just shoved up between Styrofoam and plastic cover).

 

It was a relatively new refrig, (only a little over a year and half old), that a property manager got for a good deal - obviously because the owner before them had problems that who ever worked on it before couldn't figure out.

 

Once I found the refrig thermistor out of place and removed the complete air diffuser tower in the refrig section all the way down to the crisper, I found most all of the lower air distribution channels all taped over especially down at the crispers were it would really freeze things.  Untaped all taped up air channels remounted the thermistor in the correct location and attached with foil tape so that it wouldn't move out of position and haven't had anymore problems.

Edited by Budget Appliance Repair

Share this post


Link to post
Share on other sites

Wow, great troubleshooting, Willie!  Thanks for posting that!  

Share this post


Link to post
Share on other sites

Don't know if it was great trouble shooting or just banging my head against a brick wall for awhile tell I got it figured out it seemed like :wacko:

 

I think like about 8 visits, (two of them after they replaced the refrig with a new one and moved this one to a vacant rental to let me finally figure it out).

 

1) diagnosed defrost problem, all ice up, de-iced to get them by and try and get some info here (couldn't get any thermistor specs) and thought it was a bad freezer thermistor

2) replaced freezer thermistor and de-iced

3) RECALL - had more info now and found bad control board

4) replaced control board and de-iced

5) RECALL - now it's freezing food in refrig and especially stuff in crisper drawers

6) Found thermistor out of place and just removed top section of air diffuser tower and put back in place, (noticed broken thermistor clip but thought I had it secured in position), didn't want to and didn't think I should have to remove all contents from refrig.  It was kind of difficult to get back in place without complete air tower being removed.

7) RECALL - said it's still freezing in refrig - they replaced the refrig with a new one and moved this one to a vacant rental, went out and find thermistor pushed out of place when pushing top back section of air diffuser back in - what I thought when I left last time was the thermistor still in place with just Styrofoam - thermistor rolled up between Styrofoam and plastic housing.  Now with an empty refrig removed complete air diffuser tower all the way down to crisper drawers and found all taped up air ducts.  Attached thermistor in place with foil tape and installed air diffuser tower as all one section with out having to push top part in and disturb thermistor position.

8) Follow-up visit all temps good and haven't had anymore problems with it.

Share this post


Link to post
Share on other sites

8 visits!  Not only good troubleshooting but tenacity, too.  Great job!  

Share this post


Link to post
Share on other sites