Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

DurhamAppliance

Frigidaire Affinity Washer FAFW3517KR1 spin problems

10 posts in this topic

Okay, new door switch but washer spinning sluggishly  Sometimes spins at full speed under load but always spins normally when it is empty.   Pump is fine, steady stream of water discharge and there are no obstructions. Used our test door switch and it does the same thing as the new one so door switch problem is ruled out.  No error codes. The belt does not appear to be slipping. Sometimes with only a towel in it, it will get up to speed but only when there is one minute left on the timer and doesn't spin long enough. Take the towel out, and it works perfectly.   Luckily, customer brought this thing to our shop but is has started to  consume lots of time. If repairclinic had a board in stock we would replace it just to see what happens. Other than that, any suggestions?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Bad drum bearings will bind the drum and make it do weird things under dynamic conditions (geek-speak for "spinning").  Check 'em out:

 

http://youtu.be/OThhUNI0oL8

Share this post


Link to post
Share on other sites

Bad drum bearings will bind the drum and make it do weird things under dynamic conditions (geek-speak for "spinning").  Check 'em out:

 

Unfortunately, that was one of the first things we checked. New development, tonight we could not put it in test mode....looking more and more like a board problem.

Share this post


Link to post
Share on other sites

If the control board will not go into test mode, then it is bad right off the bat.

Share this post


Link to post
Share on other sites

If the control board will not go into test mode, then it is bad right off the bat.

I suppose this would also be true with just about any board?

Share this post


Link to post
Share on other sites

I suppose this would also be true with just about any board?

. It is probably true here but I'm not sure if it is true across the board (pun intended). .... http://appliantology.org/topic/39179-trouble-entering-diagnostic-mode-kenmore-fridge-59676603600/?p=245055

That's one of the reasons I always advise check your thermistors although I may seem to be...

beatdedhorse.gif

Edited by DurhamAppliance

Share this post


Link to post
Share on other sites

. It is probably true here but I'm not sure if it is true across the board (pun intended). .... http://appliantology.org/topic/39179-trouble-entering-diagnostic-mode-kenmore-fridge-59676603600/?p=245055

That's one of the reasons I always advise check your thermistors although I may seem to be...

beatdedhorse.gif

 

 

Good pernt, Brother Durham.  Only thing that bothers me about the resolution in that topic you linked to was why the thermistor would have caused the board to not go into diagnostic mode.  Only thing I can think of is that the thermistor was shorted and loading down the board.  Do you recall what the failure mode of thermistor was in that case?  

Share this post


Link to post
Share on other sites

Good pernt, Brother Durham. Do you recall what the failure mode of thermistor was in that case?

No, I don't remember. Should have been more diligent in fleshing out my theory. This was the second time it happened to me. The first time and birth of my theory was about a year ago with a GE fridge GSS25WGPAWW. Could not get it in test mode to check themistors. Tested them manually and replaced bad ff thermistor. Solved problem and I was able to get in test mode. Next time I will record thermistor ohms as well as volts. Never delved into volt checking of thermistors at the board as I saw no need. Could be something to look at with regards to load.

As I ponder your question a bit more, it is possible those boards were becoming bad in that they could not handle any load issue created by a failed thermistor. I did create one of those shunt load testers for GE mainboards but have rarely used it. Would have been useful to know the results if I had used it.

Edited by DurhamAppliance

Share this post


Link to post
Share on other sites

For what it's worth, I always have a crazy hard time getting E-lux laundry machines into self-test.  The procedure their engineers program in is further proof that Elux/Frigidaire will only hire engineers who hate field technicians with a passion. 

 

I have had a lot of front loaders that were fine machines but installed incorrectly.  What's the flooring like under this beast?  Is it on a pedestal?  

Share this post


Link to post
Share on other sites

Yeah its on a pedestal. We changed board and now everything seems fine other than the extremely brittle faceplate covering the interface/board and dispenser. Got to glue it back together. What a piece of crap.

Edited by DurhamAppliance

Share this post


Link to post
Share on other sites