Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

The days of Monkey Boy Service Calls are over...

Click here to check out our fun short course and learn how to get the most out of Appliantology.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
AlexM

Danby Silhouette Beverage Fridge - no power to compressor

9 posts in this topic

This Danby Beverage Fridge Model# DBC2760BLS is not cooling.   Both evaporator fans work well, the compressor and condenser fan not working.  I put a hard start kit on and could only get it to start the compressor with a external 120v power cord, the it seemed to run fine.  Is this as simple as replacing the relay and capacitor?  Also, is this a Samsung? and does anybody have the service manual?  Thanks

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Is there 120 v. A.C. to the condenser fan and the compressor ???

Share this post


Link to post
Share on other sites

No, some weird voltage coming from the capacitor, but yes to the fan when I had my cheater cord plugged into the start kit, fan ran great then.

Share this post


Link to post
Share on other sites

do you have a tech sheet or wiring diagram you could post ?

Share this post


Link to post
Share on other sites

Does this unit have a two zone cooling capacity??? ................. two evap fans..................Is there an electronic board that runs the two zones????.....Hidden in the back,  If I remember........

Share this post


Link to post
Share on other sites

Sensei     u right it does have 2 zones. those boards go bad also when 1 zone goes out (restriction etc) the 2nd zone will work for 24 hrs & then shut down ALSO.

Share this post


Link to post
Share on other sites

Yes this does have the two fans, one in each compartment and no I didn't get my hands on a wiring diagram....

Share this post


Link to post
Share on other sites

OK so i installed both control boards and main board P/N DG3-45, and new Start Relay P/N QP2-4.7, and new Overload P/N B99-125.  I plugged the unit back in and all I get is a consistent beeping noise and flashing blue lights on the interior, its a quick beep, like one per second.  I pressed the control buttons in various ways trying to reset the unit, didn't work.  Did I get a bad board? is there something else I'm overlooking?  Oh and the evaporator fans 'jump' but don't turn everytime the beep happens.

Share this post


Link to post
Share on other sites

Sounds to me (JUST A GUESS) that you should put the old boards back in and see if the evaporator fans are still running normal. then I would check the power into the board, and check the power relay on the boar for the compressor, and condenser fan motor. there should be a wiring diagram some where on the unit. Try looking behind the kickplate, under the front of the unit too.

Share this post


Link to post
Share on other sites