Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Viking VDSC4854GGG 48" DUAL FUEL

RH oven no bake no broil

  • Please log in to reply
5 replies to this topic

#1 prairiestr

prairiestr

    Kohai

  • Chief Appliantologist
  • PipPipPip
  • 271 posts
  • Flavorite Brew:Jack

Posted 09 January 2013 - 08:24 PM

I'm gonna need help with this one.

 RH oven no bake or broil. Elements ok. Tough to read wiring diagram. Very small.

L1 present at red wire at selector sw.

L2 appears to be present at wt/bu wire at sel.sw.

In bake position, thermostat set 350, 240v between red(L1) and wh/bu(L2) at selector sw.

Yet, no heat?

Help please.



Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 KurbyMstr

KurbyMstr

    Sōhei

  • Professional Appliantologist
  • PipPipPip
  • 116 posts
  • Location: USA
  • Flavorite Brew:Cherry Coke

Posted 09 January 2013 - 10:26 PM

Are you getting any voltage at the elements themselves?  Do you have a model number so we can take a look at the wiring diagram?



#3 prairiestr

prairiestr

    Kohai

  • Chief Appliantologist
  • PipPipPip
  • 271 posts
  • Flavorite Brew:Jack

Posted 10 January 2013 - 12:10 AM

Model # listed in topic title. VDSC4854GGG

I didn't check voltage @ elements, :stupid:  but I would guess that 0v across and 120v to ground.



#4 KurtiusInterupptus

KurtiusInterupptus

    B.M.F.

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,878 posts
  • Flavorite Brew:Killians Red

Posted 10 January 2013 - 07:54 AM

Check for burnt wire/terminal at big molex plug at right and/or left rear corner.
As every cockroach knows , thriving on poisons is the secret of success.

#5 KurbyMstr

KurbyMstr

    Sōhei

  • Professional Appliantologist
  • PipPipPip
  • 116 posts
  • Location: USA
  • Flavorite Brew:Cherry Coke

Posted 10 January 2013 - 10:53 AM

My bad on the model number. I'm with Kurtius on checking the wiring.



#6 prairiestr

prairiestr

    Kohai

  • Chief Appliantologist
  • PipPipPip
  • 271 posts
  • Flavorite Brew:Jack

Posted 10 January 2013 - 02:05 PM

Kurtius & Kurby,
Thanks for the tip, I'll try to check that today. :thanks:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics