Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Lanzz

Sub Zero 511 - Warm Fresh Food Compartment

21 posts in this topic

I came home from 4 days in Tampa to find my fresh food compartment almost as warm as Tampa.  :-( 

 

Over the summer, I had the fresh food evaporator replaced, and the R12 replaced with some other refreigerant (R414a or something..)  This worked very well for a time...  it was an expensive repair, but I assumed I could squeeze a few more years out of the fridge

 

For the past few weeks, the fridge seemed to be noisier than before, and the kitchen seemed a bit hotter, as a result of the fridge, but I am not home too much, so I figured I was imagining - perhaps not.

 

So - the freezer is ice cold stll.  The lights work, both compressors are pretty warm to the touch, and the fan runs when I close the door switch manually.   The condenser fan at the top is not turning, but I am not sure if it is supposed to be.

 

Serial # is M806968

 

Manufacture date is October 1989

 

Am I at the end of the line with my beloved 511?  (Not to mention being $2,100 lighter for the repair over the summer...)

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... The condenser fan at the top is not turning, but I am not sure if it is supposed to be.

Serial # is M806968

the Condenser Fan on that model / serial number is powered continously

(bad Fan)

 

If the Fridge Evaporator Fan is running, the Fridge Compressor should be running..

You may need to take a look at the Fridge Evaporator frost pattern

(post pictures) ?

Share this post


Link to post
Share on other sites

Hmmmm...  I did some more looking around...   1)  When I advanced the defrost timer manually, the condenser fan started running.     2)  I looked at the (shiny new) evaporator, and with the fresh food compressor and condenser fan off, there were water droplets on it, but not frost.    3)  I increased the fresh food cold control to 6 (I usually keep it on 1, because that is cold enough, and NYC electricity is 27 cents per KwH) and now the fresh food compartment is cool, but not frozen over.

 

Does this shed any light on the issue? 



Still seems like the area in front of the grill at the top of the unit is very warm - like it is in distress or something.   Not sure if that means anything, but does not seem like it was always that warm. 

Share this post


Link to post
Share on other sites

...  1)  When I advanced the defrost timer manually, the condenser fan started running.  

...  2)  I looked at the (shiny new) evaporator ... there were water droplets on it, but not frost.   

1) are you sure ? ... Condenser Fan runs continuously ... top of unit ... cools both Compressors

Freezer Evaporator Fan is controlled by Defrost Timer (and Freezer Cold Control) (and Freezer Door Switch)

 

There is no Defrost Timer for the Fridge side ...

 

2) Fridge Compressor would need to run one or two hours for a good frost pattern on the Fridge Evaporator ..

The Fridge Compressor should run anytime the Fridge Cold Control calls for "cold"

and the Fridge Evaporator Fan should also run (if the Fridge Door is closed)

Share this post


Link to post
Share on other sites

Definitely sure that the condenser fan ( the one behind the grill at the top ) was not running when I took the grill off.  It started when I advanced the defrost timer.  (or perhaps it started because I had the fridge door open for a time to look at frost pattern...  those things happened at the same time)    I will look again at frost pattern in the AM - the frige is definitely cooler now, but it was not too cool when I got home earlier tonight.  

Share this post


Link to post
Share on other sites

ok - did some poking around today.  Frost pattern looks even, goes to the bottom of the evaporator.  I think I caught it as it was starting to melt, so some water droplets started to form as I was poking around.  

 

both evaporator fans operate when door switches are closed and compressors are running.

 

condenser fan looks to be the issue - running now, even with compressors off, but it wasn't when I got home last night.

 

any suggestion on where to get a new compressor fan replacement motor/kit? 

Share this post


Link to post
Share on other sites

any suggestion on where to get a new compressor fan replacement motor/kit? 

4200740

eBay / Amazon

Share this post


Link to post
Share on other sites

Thanks - just ordered from Amazon.  Will keep you posted on progress.  Ed

Share this post


Link to post
Share on other sites

I caught the condenser fan snoozing on the job today.  So - a question...  While I wait for the new fan motor, is there a risk of compressor damage or fire when the fan stops running?  Seems like things get pretty hot up in front of the grill - not like fire hot, but hotter than normal nonetheless.   Just wondered if I should rig up some temporary fan or something in the mean time, or if I am doing anything dumb while I wait for the part. 

Share this post


Link to post
Share on other sites

... is there a risk of compressor damage or fire when the fan stops running? 

not fire, but life expectancy of the Compressors would be reduced ..

a standard window box fan would work ..

Share this post


Link to post
Share on other sites

While you are waiting , you could go to your local appliance store and ask for motor P/N 61021  it will work , I keep one on the truck for a replacement motor........

Share this post


Link to post
Share on other sites

OOOPPPPPPss........, :rolleyes:       my bad............I shuda listed the parts places also................Reliable...... :thumbsup:    or W.L. May.. :thumbsup: .........................P/N 61021 is a             ' Condenser fan motor...  Dual foot mount,  Standard 51 frame.....2 watt.'...............About 45 clam$....................................

Share this post


Link to post
Share on other sites

Thanks all, motor arrived today - just finished installing it.  Total cost:  $42.88, which is less than the cost of a parking ticket for the service man to come and visit me.  A few observations:

 

1.  You boys who work on appliances earn your money, it was hard to work around all those other parts and get the the new motor installed  (took me almost 3 hours)

 

2.  It's dirty up there and a lot of the parts are hot 

 

3. The insulation on the wires to the old fan motor had completely fallen off, exposing the bare wires - very glad I replaced it - looked pretty unsafe in its current condition

 

4. I think the old fan motor had been failing for years - because the new one spins a whole lot faster

 

Thanks again - we are keeping a close eye on the Coors Light here in apartment 20D - very important that it stays cold!!

Share this post


Link to post
Share on other sites

Here are the pictures uploaded to the gallery...  Hope these show correctly. 

 

Share this post


Link to post
Share on other sites

Good Job !   Great Pic's !    I C both systems have had process valves installed, been serviced before

Share this post


Link to post
Share on other sites

All of the units I have worked on came from the factory with the process tubes installed..............................The compressor(s) look factory,  The capillary tubes are still attached to the floor  ( I disconnect to pull comp. under the tubing  )......The refer Schrader valve looks different thou...............About an hour job, just because you gotta be care full  not  to do any damage to the door or the outer frame around the compressor compartment............And I carry a lot of protection ..... :thumbsup: .

Share this post


Link to post
Share on other sites

You probably needed new fan motor, but from the looks of it  your problem may not be solved.  Did you check the evaporator coil to see if its clean?

Only way is to put drop light in front of it while you look from the back side, (fan side).  You must see strong light as you move it about or else

use compressed air or a reversed shop vac to blow it.   That condeser coil is prone to geting cloged up. 

Share this post


Link to post
Share on other sites

Fridge evap is new in July, and I vacuumed / blew dust out of condensers when I had it apart yesterday.  What a mess - 23 year old dust all over the kitchen. 

 

As of now, fridge and freezer are cooling normally, exhaust out of the top is a lot cooler, ice maker is making ice.  

 

I plan to take the grill off in the next few days to check everything one last time before I declare a full victory. 

Share this post


Link to post
Share on other sites

Nice work!  Keep the condenser clean - vac 2x a year from now on and you should not have this problem again!  Brings back memories from my Sub Z days ... and burnt patches on my forarms from changing condenser fan motors with the compressors screaming hot!  lol.  

Share this post


Link to post
Share on other sites

Excellent use of the Gallery section of the site!  

Share this post


Link to post
Share on other sites