Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

The days of Monkey Boy Service Calls are over...

Click here to check out our fun short course and learn how to get the most out of Appliantology.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
DanInKansas

GE GSH25JFTAWW -- condensation in freezer, poor performance

5 posts in this topic

Went out today on this refrigerator.  Complaint was poor performance in freezer. 

 

Lots of condensation on the augur motor box and the IM direction solenoid is frozen in place.  Customer complained of bad freezing performance; everything was frozen when I arrived.  Temperature was set to "8" with "9" the coldest possible setting. 

 

Baffles opened and closed but took a long time to respond to controls and had a grinding sound when doing so. 

 

Went back to the control board and took thermistor readings.  Evap thermister made sense, showing about -10F.  Freezer thermister was way off the mark, was showing freezer at about 23F, when actual temp was 16. FF compartment showed a correct temperature of about 41F.  When I plugged the unit in and restored function, I had to push the FF setting to "8" before the baffles finally opened and I had my grinding sound again.
 

My question: I am going to replace the baffles and the freezer thermister.  Should I also replace the board, given that it should have been opening the baffle based on the temp sensor reading?  Or GEs just take a longer time to respond to temperature sensors than other units? 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Not sure about the grinding sound... Probably ice in the damper.  I suggest you replace the bad thermistor first. If

the  thermistor is telling the board the freezer is not cold enough, the compressor will continue to

run, freezing the icemaker  and icing the damper and the damper will stay closed trying to satisfy freezer requirements before opening and satisfying fresh food requirements.

Share this post


Link to post
Share on other sites

Went out today on this refrigerator.  Complaint was poor performance in freezer. 

 

Lots of condensation on the augur motor box and the IM direction solenoid is frozen in place.  Customer complained of bad freezing performance; everything was frozen when I arrived.  Temperature was set to "8" with "9" the coldest possible setting. 

 

Excessive condensation always indicates an air leak somewhere.  (See my enlightening blog post for more about that.)  Check door gaskets (both doors) make sure they're sealing all the way around, check door hinges, make sure doors are closing properly, and check the dispenser flap, make sure it's closing all the way.  

 

Baffles opened and closed but took a long time to respond to controls and had a grinding sound when doing so. 

 

Open both doors, quickly close the freezer door. Listen for the slapping sound of the damper door closing.  If it's not closing like that, the damper flap and actuator may have rime ice stuck in the mechanism.  Or the damper assembly has been damaged.  This unit uses the mylar damper assembly.  More info on its operation here ==> http://appliantology.org/files/file/625-ge-refrigerator-mylar-damper-assembly-training-bulletin/

 

The damper assembly also has a thermistor and both are replaced as an assembly ==> http://www.repairclinic.com/PartDetail/Thermistor/WR60X10215/1195786

 

 

 

Went back to the control board and took thermistor readings.  Evap thermister made sense, showing about -10F.  Freezer thermister was way off the mark, was showing freezer at about 23F, when actual temp was 16. FF compartment showed a correct temperature of about 41F.  When I plugged the unit in and restored function, I had to push the FF setting to "8" before the baffles finally opened and I had my grinding sound again.

 

 

The evaporator thermistor is the most troublesome on these.  It's attached to the evaporator and sees alot of temperature extremes and moisture   It controls defrost cycle.  Check it (and all thermistors) by placing it in a glass of ice water and measuring resistance.  Should read about 16.3 k-ohms in 3-5 minutes.  Can measure at muthaboard.  Pinout layout below.  If off-spec, replace ==> http://www.repairclinic.com/PartDetail/Thermistor/WR55X10025/914093

 

gallery_4_4_340323.jpg

 

 

 

gallery_4_4_163965.jpg

Share this post


Link to post
Share on other sites

Did check door seals, did not check the dispenser flap.  Neat trick with the freezer door slam; will have to remember that. 

 

I have to confess, GE SXS make me into a part-changing monkey.  At this point I have had enough bad experiences with them that I am gunshy and have a tendency to shotgun.

Share this post


Link to post
Share on other sites

It's really not that bad once you understand that it boils down to a single-board computer (a muthaboard) that talks to peripheral components (thermistors, heaters, fans, dampers, etc.)  If you know what the specs are on the components and what control voltages you're looking for from the muthaboard, then it's just a logical progression; see this blog post on how to troubleshoot any appliance ==> http://appliantology.org/blog/1/entry-543-how-to-troubleshoot-any-appliance/

 

This is the way of the future and not just for refrigerators-- all appliances are going this way.  But once you learn the basic way of thinking about how the controls are done in this new regime vs. the old discreet mechanical controls, it's really straightforward and usually makes for jobs with a higher profit margin.  

Share this post


Link to post
Share on other sites