Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
JoeZ34

Kenmore washer not spinning fast enough

3 posts in this topic

Hi,

 

I have a Kenmore 110.20932991 Elite washer. The clothes are still wet after the spin cycle completes.

What I have done so far.

1. Removed the washer cover, and checked between the two tubs for a lost sock or some other item.

2. Checked all water drain lines for blockage.

3. Removed water pump from motor and checked for blockage. Was able to spin pump by hand.

The washer agitates strong so that rules out the motor coupler, and the pump / water flow is strong when draining. I also have verified that the tub is spinning I can see the tub spinning if I open the door just a bit before the cover switch shuts it down.

If I put a small load of laundry in the washer, (like 2 towels) the washer works!  However under a normal load (and I also verified that the clothes were balanced properly) the clothes are still wet after the cycle.

 

Any advice as to what to look at next would be appreciated.

Thank You,

Joe

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

During pumpout, lift the drain hose so you can observe the discharge stream, should be the same diameter as the drain hose and full n' strong.

Is this is an unusual drain hose configuration, e.g., discharge is above the washer?

Share this post


Link to post
Share on other sites