Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
charliefoxtrot

Subzero 680 ice/water thru door not workin'......

5 posts in this topic

So we had a generator transfer switch put in....and somehow it fried the neutral buss bar in our subpanel that feeds kitchen. (we never even used the transfer switch, it was faulty switch, but I digress)

It burnt up the dispenser on our 680, the circuit board inside the dispenser was smoked, nothing else on fridge was affected.

 

I got a new dispenser, plugged it in, and the little bulb lights up when you hit the button, and I hear a small click like a relay clicking, but the solenoid that moves the  ice chute door open doesnt move. I have 115v at the black wire, white wire, and yellow wire. Zilch on the remaining wires, red brown and white.

 

Now, I believe the short killed the part of the circuit board that controls the dispenser, it seems logical anyway. Manuals I got here didnt seem to cover much in the way of the dispenser.

I pulled the board and looked it over carefully and saw no visual damage fyi. 

 

Would love some help, thanks much!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

anyone?

Share this post


Link to post
Share on other sites

Did you check to see if the dispenser is locked. If not you may have a problem with the dispenser housing assembly. But  I  have to defer to the other masters re wiring issues with your model.

Share this post


Link to post
Share on other sites

Using the  600 series  manual   # 3758407

.....what is your serial number ?????............................  Black wire???.. to main control board or disperser board ???...............The manual I haz, no black wire to/from the dispenser board....Yellow appears to be power 'in'.................Brown, power out to auger and the motor.............Did you check the solenoid Ohms. value???    100 by my book....... Power out at the two wires to the solenoid????................Does the auger motor operate when the auger switch is closed  and dispenser button is pushed ??????  .....................

Share this post


Link to post
Share on other sites

See,  that's what happens when a master is called in.  You better have done your homework. lol

Share this post


Link to post
Share on other sites