Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***CLICK HERE AND READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
alexeinspruch

GE Monogram ZDIS150WSSC high capacity ice maker not making ice

16 posts in this topic

I'm at my inlaws......machine was working fine and apparently came home to an empty machine. It makes noises like it's filling and draining but still doesn't make ice.

Compressor coils cleaned. They ran vinegar and water through the reservoir. We purchased the green cleaner as well but have not tried it. I just checked the machine and the CLEAN light is lit.

Not sure what to try next.

Edited by alexeinspruch

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Is the Compressor running ?

Does the Evaporator Plate get cold ?

Share this post


Link to post
Share on other sites

I reached up inside at the top to feel the evaporator plate......it is actually quite warm. We will have to pull the machine out from under the countertop to check compressor, correct? Is the compressor fused separately from the rest of the icemaker?

Edited by alexeinspruch

Share this post


Link to post
Share on other sites

Compressor is running. We pulled the unit out from under the counter. Now running the factory clean cycle with the Hydroclean...

Edited by alexeinspruch

Share this post


Link to post
Share on other sites

... the CLEAN light is lit.

then it's in the 47 minute Clean Cycle

To exit Clean Cycle, press ON or OFF

Share this post


Link to post
Share on other sites

I could still see some Hydroclean when I drained the pan so I'm running it again. 7 minutes left.

Share this post


Link to post
Share on other sites

Ok. The cleaning cycle did not seem to want to finish even after 70+ min, so I ended it by pressing the off button and holding it down. I then drained the pan. Next I pressed the on button. Pan now refills and both the ON and CLEAN lights are illuminated.

Share this post


Link to post
Share on other sites

The CLEAN light remains constantly illuminated. I don't know where the dirty parts are but water is reaching the condensing plate to produce an ice sheet....that much I know. Peering through the plastic guard up top which blocks the heated grate I see water cascading down....

Edited by alexeinspruch

Share this post


Link to post
Share on other sites

It works now......

Share this post


Link to post
Share on other sites

Fast forward. Some ice, but mostly reservoir filling and emptying endlessly. CLEAN light still on...

Share this post


Link to post
Share on other sites

Open the control panel and remove the wires from the On/Off and the Clean switches.

Ohm the switch to see if Clean is continuous when off.

Leave the Clean wire off the switch and replace the On wires and start the machine to see if it stays in the ice making mode.

You have either a bad push button switch or a bad control board.

Share this post


Link to post
Share on other sites

Water runs only after I opened the door for about a minute....

Share this post


Link to post
Share on other sites

Did you ohm the pushbutton switches to verify them opening and closing correctly?

Share this post


Link to post
Share on other sites

No not yet.....stand by.

Share this post


Link to post
Share on other sites