Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to troubleshoot like a Master Samurai Tech...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
deezus

Thermador Range Mod#PGR366Z501 bad switches?

4 posts in this topic

This units front left burner wont light and no gas comes on when you turn switch but electrode does spark. The front right burner will not light every time.....it will spark then stop and gas comes out as you turn switch. Its stops sparking right before gas comes out so you have to catch it right. All other burners and oven work fine. I believe I have two bad potentiometers. On the front left switch I see two wires coming off the potentiometer to a connection at the gas line going to the burner. Please help, Thanks.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Anyone? I think the front left might be the potentiometer as that controls the solenoid from opening valve. And the right front like I said before stops sparking just before gas comes out. Any help would be awesome...

Share this post


Link to post
Share on other sites

Have you checked the continuity of the gas valve solenoid for the FL burner? I replace a lot of those. Should also check to see if you're getting 24vdc to it. The manual you downloaded has details on isolating and troubleshooting the solenoid vs the reignitor vs the potentiometer.

Share this post


Link to post
Share on other sites

Ok, so when burner is turned on their should be 24 volts at valve? If not bad potentiometer ? If there is bad solenoid. The other front burner on right won't light everytime. It stops sparking right before it lights. Ty forthehelp btw.

Share this post


Link to post
Share on other sites