Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

elmonducky

Frigidaire Double oven PLEB30T8CCB No bake either oven

10 posts in this topic

No bake either oven, broiler comes on to assist in preheat but no bake.  Elements check good.  Not familiar with this model could not figure out how to remove oven to check thermostat.  Any suggestions??

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... No bake either oven, broiler comes on to assist in preheat but no bake. 

... Elements check good. 

 

sounds like a bad BAKE Relay on each Relay Board,

OR a bad Oven Controller,

not sending power to the Relay Coils

 

http://appliantology.org/files/file/769-frigidaire-oven-pleb30t8ccb-parts-list-wiring-diagram/

 

http://www.repairclinic.com/Frigidaire-Range-Stove-Oven-Model-PLEB30T8CCB-ID-626372-Circuit-Board-Timer-Parts

Share this post


Link to post
Share on other sites

Hmmm,  would like to be able to remove this from wall to verify.  Looks like side trim needs to be removed to access screws that mount wall oven to cabinet.  Removed all visible screws but still not able to remove.  What am I missing??

Share this post


Link to post
Share on other sites

Thanks, im wondering if the thermal breakers are open due to perhaps a cooling fan failure?  Looking for a common denominator.  But it looks like if the thermals are open the broiler wouldn't work either.  The control board seems to be the only component in common but the broilers heat up when put in bake so hard to believe that would be the cause.

Share this post


Link to post
Share on other sites

did these problems happen at the same time ?
OR months or years apart ?

Were the Bake Elements possibly bad, (causing Relay failure)

and someone else replaced them ?
 

Share this post


Link to post
Share on other sites

Elements have never been replaced to my knowldge.  The customer seemed to indicate that the top oven went out before the bottom one.

Share this post


Link to post
Share on other sites

Follow up, turns out both upper and lower relay boards were bad

Share this post


Link to post
Share on other sites

Wow, very unusual for two boards to blow at once.  Wonder if there was a power surge that took 'em both out.  Good job on the fix and thanks for letting us know!  

Share this post


Link to post
Share on other sites

did these problems happen at the same time ?

OR months or years apart ?

Were the Bake Elements possibly bad, (causing Relay failure)

and someone else replaced them ?

 

Share this post


Link to post
Share on other sites