Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to be your own tech line...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
dimitri77565

KitchenAid Refrigerator Dispencer

5 posts in this topic

Went to a K.A. refrigerator sxs no ice dispensing.  Motor looked rusted leakage from  Shaft tested read bad, well that did not solve problem.  You know every time you think you have it & get cocky , Bam you trip.

Seems the push paddle was not working also, & some how it was not showing good on microfilm so I took it with me.

Special order, blah blah , Tim "The Counter Parts Man" said hey lets take it apart, Duhh why did I not think of that?

Well sure enough it was full of black grease or melted rubber? dont know , but after I cleaned it with keyboard cleaner it works good. To be Installed Wednesday.

 

1.1 well pictures did not up load , any one know how? will try again tonight, got to go pay some bills

 

http://appliantology.org/gallery/image/714-inside-view/

http://appliantology.org/gallery/image/713-front/

http://appliantology.org/gallery/image/712-rear/

 

you can still see some smudges in the inside view

Edited by dimitri77565

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

In door ice bin I'm guessing.  Need model #.

Share this post


Link to post
Share on other sites
...  1.1 well pictures did not up load , any one know how?

picture file size 200k limit

OR upload them to a photo file website,

then post the links here

Share this post


Link to post
Share on other sites

 

1.1 well pictures did not up load , any one know how? will try again tonight, got to go pay some bills

 

 

For a series of photos, it's best to make an album in the Gallery section and upload them there.  Virtually no limits.  

 

Share this post


Link to post
Share on other sites

Either unit lost power with a bin full of ice or there's some warm air intrusion at ice door.  Bad door motor or damaged hinge depending on model.  Have had new auger motors strip at the drive bar insert by not catching ice door problem during initial check.  Also check wire harness to auger motor for corrosion.  No replacement or repair for severely damaged wire harness to my knowledge.  Have to replace freezer door assy and that can be major dinars.

Share this post


Link to post
Share on other sites