Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to be your own tech line…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
ars

GE Side by side frig - Freezer too warm -GSS25SGRB

12 posts in this topic

Hello all,

 

Last week (Thursday) I noticed the items in the freezer were soft.  The icemaker was still occasionally making ice, however.  The frig seemed to be working fine.  I removed all the items from the frig, unplugged the frig for a day and then re-plugged it in and put thermometers in both.  Since then the frig temperature has stayed at a constant appropriate temp of 35.  The freezer temperature has not dipped below 32. 

 

I went various checks to see if I could find the problem.  Here is what I did:

 

-checked door seal

-checked to see if light was turning off

-checked to see if little door in ice dispenser was closing

 

- removed back panel and cleaned condenser

-looked to see if condenser fan was running

 

-looked to see if coils in freezer were all frozen over

-checked drain in freezer

- unplugged frig and left it unplugged for 24+ hours

 

The freezer did not seem to be overly frosty. 

 

-listened to see if evaporator fan is running.  I think it is.  I assume there are only two fans in the frig--the condenser fan and the evaporator fan?  I can hear a fan running in the freezer and can feel air blowing out.

 

-looked to see what type of thermistors were in there.  They are the open bottom kind. 

-looked at the main control panel, but I don't know what I would look for.  Nothing seemed obviously broken or burnt.

 

I'm assuming maybe the thermistor in the freezer section is broken?  Or maybe the mother board?

 

Any suggestions or assistance you can provide would be greatly appreciated.  My level of technical ability is pretty low.  I can swap out parts and disassemble stuff.  I have fixed two washers and a dryer, but those were very simple obvious problems.  My general approach to fixing stuff is to open it up and see if there is anything immediately apparent. 

 

Thanks again.

 

 

PS:  Forgot to add that although the GE diagnostics in the service manual show a control panel that is just like my frig's, there is no "hold" button to press to start the diagnostic running.

 

 

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... looked to see if coils in freezer were all frozen over

... The freezer did not seem to be overly frosty. 

post a picture or describe the frost pattern

Share this post


Link to post
Share on other sites

The evaporator frost patterns are a big clue as to what is going on. Evenly frosted over all of them, or only at the top?

Share this post


Link to post
Share on other sites

fixit, why are you starting multiple topics for the same problem?  Just post your replies or followup questions in this topic.  

Share this post


Link to post
Share on other sites

 

 

PS:  Forgot to add that although the GE diagnostics in the service manual show a control panel that is just like my frig's, there is no "hold" button to press to start the diagnostic running.

 

You have the 4 button display and cannot enter diagnostics with that particular interface. You are gonna have to test it the old fashioned way. or get a diagnostic kit

Share this post


Link to post
Share on other sites

fixit, here's the part links to the diagnostic test kit that Brother Duraham described to you:

 

Interface and touchpanel kit:  http://www.repairclinic.com/PartDetail/User-Control-and-Display-Board/WR55X10390/1092891

 

Wire harness:  http://www.repairclinic.com/PartDetail/Wire-Harness/WX05X14999/914872

Share this post


Link to post
Share on other sites

Does your control panel have any other button besides the four up/down temp buttons?

 

Like maybe a "Turbo Cool" button way over to the right, I'm working on a SSL27 model, I was able to get it to go into diagnostics by using the "Turbo Cool" button instead of a non-existing "Hold" button.

 

The problem I have is I set both refrig/freezer settings at number 5 as required and try to push all the buttons at the same time but almost every time one button is pushed before others and the numbers change.  Have had very difficult time getting all four pushed at the same time to get the 0 0 flashing to even start diagnostics, anyone have any hints on how to push all four at the same time and not change the temp setting causing it not to enter diagnostics?

Share this post


Link to post
Share on other sites

if there is any other button, budget is right, as your fridge would be deemed a 5 button display. To enter diagnostics, after you get the blinkkng 0's, you have to press any button other than temp up or down button. Sometimes pressing all the buttons simultaneously can be aggravating as heck (should have said "hell" cause nuthing can be as aggravating as hell, i suppose.. except maybe trying to put some of these fridges into diagnostic mode).

Share this post


Link to post
Share on other sites

Hi everybody, thanks for all your input.  With regard to the frost pattern, I didn't look at it because I didn't realize it was diagnostic.  (I did read much of the frig stuff here but missed that part.)  An exploratory finger stuck behind the freezer panel didn't feel any big block of ice.  Not much water dripped out when it was unplugged for 24 hours, either.  There was what appeared to be a scorch mark on the back of the panel (the side facing the coils).  It is towards the bottom, near what I suspect might be the defroster for the thing.  (Never opened up an auto-defrost frig before--very interesting.)  I plugged the frig back in yesterday and will look at it in a day or so. 

 

With regard to the multiple topics, I'm sorry, I didn't mean to do that.  I edited the post and it double-posted but I couldn't find a delete box.  Also the "Reply to this topic" didn't show up before.  (?)

 

With regard to the diagnostics, the service manual I have uses an illustration of the same key panel that is in my frig.  But there is no other button, no hold, no turbo cool, nothing.  What's funny is that the frig will display the blinking "O's".  Pressing all the buttons at once is quite a trick, however.  I had to press really hard.  With another tech thing that required a simultaneous button press too long for my hand, I made a little thing out of wood.  That would probably help with the button pushing, Budget Appliance Repair.  ;0)

 

I tried calling GE but the person who answered tech support knew less about frigs than I do, if that is even possible.  The rep claimed the diagnostics could be run on a four-button panel but didn't know how and the thermistor is located under the toe kick, among other things. 

 

Right now I guess the problem might be with the defroster, the thermistors or maybe the control board.  I did look at the control board to see if it has any obvious loose connections or burnt spots, but didn't see anything.  This repair might be above my level of ability.

 

Your input is greatly appreciated.  Thank you so much.  I love learning about how to fix stuff. 

Share this post


Link to post
Share on other sites

Hi everybody,

 

Just an update. 

 

I plugged the frig back in so I could look at the defrost patterns, as Samurai Appliance Repair Man suggested. 

 

The freezer steadily got warmer and warmer, as did the frig.  Finally it was no longer keeping any sort of cooling. 

 

It appears that there is a sealed system problem.  This was confirmed by the repair person, who estimated $600+ to fix.  He recommended replacement. 

 

This frig is not all that old and it still looks great.  Seems like a pity to junk it.  By comparison, before I always had really old refrigerators and never had any problems with them.  *shrug*  Fortunately I have a beer frig to use while waiting on a new frig delivery.  The beer frig is harvest gold, which should give you some hint about how old it is. 

 

Thank you all so much for your assistance.  Although I wasn't able to fix my frig, I enjoyed learning more about the diagnostic process and the components involved. 

Share this post


Link to post
Share on other sites

I don't think I read anything about the compressor. Is it running?

Share this post


Link to post
Share on other sites